Cannot install cudnn 8.0.5 on nvidia/cuda:11.1-cudnn8-devel-ubuntu16.04

I’ve downloaded a most up to date nvidia docker build and tried to update its cudnn configuration, and it failed in updating the cudnn environment.

I’ve found the cudnn headers are a little different from installation guide. So how can I get a cuda11.1+cudnn8.05 environment?