Cannot Install Nvidia NeMo

I have tried to install the NeMo both from the command line and building from the source package. For both cases the installation failed on the installation on the sentencepiece package.

A. build from the command line
sudo pip3(or pip) install sentencepiece

B. build from the sentencepiece-0.1.91 package

Both gave me the following errors.

Can you give me the suggestions how to solve the problem?


========== Failed Message
Package sentencepiece was not found in the pkg-config search path.
Perhaps you should add the directory containing `sentencepiece.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘sentencepiece’ found
Failed to find sentencepiece pkgconfig

You need to build sentencepiece yourself. Here is another discussion on installing NeMo on Jetson with some more details: NeMo installation - done; performance to be evaluated


By folllowing the steps in: google/sentencepiece now I can install the sentencepiece.

But I try to build the tokenizers from the souce, I have got following error:

sudo python3.6 install or sudo python install

Any suggestions how to solve this problem since I can n’t figure it out yet?


sudo pip install setuptools_rust – this installation was successful before I install the tokenizer

Probably the actual error message got lost somewhere - can you specify the error message in more detail?

Hello! Is this issue solved?
I’m on python3.6 as well and I’ve tried installing sentencepice and setuptools-rust but still failing to build on tokenizer

I can install the NeMo on dGPU laptop not the Jetson

You may want to try the container for Jetson from this project, I have it built with NeMo:

Thank you so much for your awesome project! I appreciate it :-)

2021년 7월 13일 (화) 오전 2:41, dusty_nv via NVIDIA Developer Forums <>님이 작성: