Cannot install TAO v5

Hi everyone,

I am trying to install TAO toolkit 5.0 on a VM instance for deep learning on GCE. I followed the quick start guide line by line, and everything seemed okay with the installation until I tried to play a bit with the provided notebooks (e.g., DINO). In fact, the tao model command fails, preventing training, as the task group does not exist. The reason being that the installed TAO toolkit version is 4.0.1.

I just don’t get it, as I installed TAO using the provided script in the getting started 5.0 kit. How can the 5.0 kit install the 4.0.1 version? Why doesn’t the bash setup/ --upgrade upgrade it to 5.0? It was my last hope.

The requirements are all installed respecting the versions reported in the guide’s chart.

Please share the full log.

Did you download below firstly and then run bash setup/ --install?

wget --content-disposition -O
unzip -u  -d ./getting_started_v5.0.0 && rm -rf && cd ./getting_started_v5.0.0

After restartig the machine, TAO v5 correctly showed up. I am not sure why a restart of the VM instance was necessary after issuing the upgrade, but now the issue seems solved by itself. Maybe, you have a clearer idea.

Still, I don’t understand why v4 was there in the first place.

Glad to know it is working now. The video is a bit old since the latest TAO notebook is

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.