Cannot integrate CUDA Toolkit 8.0 in Visual Studio

I have a problem with integration of CUDA toolKit 8.0 in visual studio.
First i try to install toolkit with visual studio 2012 ultimate, and it failed
Then i installed visual studio 2015 Community, and it also failed
The message was Visual studio integration failed(in Russian - сбой).
Maybe smb knows what the problem. Help, please.


Could you download the standalone nsight msi installer and try to generate the log via “msiexec /i “nsight.msi” /L*V “C:\log\example.log””, then we can check if it’s installer’s issue.

Best Regards

I’v done what you’ve said, and there was one interesting message “Error 1406. Could not write value to key \Software\Classes\exefile\shell\Launch with Nsight HUD 5.2\command. System error . Verify that you have sufficient access to that key, or contact your support personnel.”
The same error was when i tried to install toolkit 8.0, but i could’t continue installation in the case of toolkit. In the case of nsight installation i’v just press the button ignore and continue.
Nsight was integrated in visual studio but i don’t know is it correct? I don’t try to launch any CUDA projects.
Also i’ve found one more error in the log file “DEBUG: Error 2836: The control NsightForVisualStudioXPng on the dialog SummaryCustomMSI5Dlg can not take focus”
Can you explain the nature of this problems, please.


Looks like you don’t have administrator privileges to write the registry.

You’re right, nsight is intergated in visual studio, if you don’t need to launch any CUDA project and you can ignore the nsight, but without nsight, you even cannot compile the cuda project.

If you do have administrator privileges, please attach your log file, then I should raise a bug for dev to investigate.

Best Regards

One more question, could you provide you OS detail, which windows you use, it’s 32 or 64 bits?

Also could you try to manually edit the “HKEY_LOCAL_MACHINE32\Software\Classes\exefile\shell\Launch with Nsight HUD 5.2\command” or “HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Software\Classes\exefile\shell\Launch with Nsight HUD 5.2\command”, add a key, edit some values, or something else.

Thank you

windows 64-bits
I can’t find folder “softwear” in Wow6432Node. There is the folder “Classes” after “Wow6432Node” but there is no folder “exefile” or smth like this.
If i find this folder Should i do this command after installation or before?
Thank you

Sorry I made a mistake, actually I also don’t have any idea about the exefile\shell :(, anyway I’ve sent the mail to dev for early investigation.

I’v just found " 00:\exefile\shell\Launch with Nsight HUD 5.2\command" in the windows\current_version\Installer\UserData\S-1-5-18\Components"addres like F8FC…"

Hello mihazloy,

Our Dev cannot find anything special in the log, could you make sure that you account has all the necessary privileges?

Also could you provide the detail information of your system? Thank you.

Best Regards

Hello Harry.
I’ve checked one more time the status of my user and i’m sure that i have administrator privileges. How can i find the file where the full windows description is situated? I just can say that it is windows 7 64-bits, but nothing else.
Maybe i should try to reinstall my windows and do another attemp to install cuda toolkit 8. I will try to do this with VS 2015 coummunity, but i’ve heard that there is some problems with 2nd and 3d version of updates.
Thank you for your help.
Best regards,

Hi, could you have a check on latest nsight 5.3?

Install with the Nsight 5.4 build. Bring up an Administrator shell, and then run msiexec as admin:

msiexec /a “NVIDIA_Nsight_Visual_Studio_Edition_Win64_5.4.0.17240.msi” /L*V log.txt


I have the similar problem.

=== Logging stopped: 16.12.2017 1:22:30 ===
MSI © (D0:50) [01:22:30:383]: Note: 1: 1707
MSI © (D0:50) [01:22:30:383]: Product: NVIDIA Nsight Visual Studio Edition – Installation completed successfully.

MSI © (D0:50) [01:22:30:383]: Windows Installer installed the product. Product Name: NVIDIA Nsight Visual Studio Edition Product Version: Product Language: 1033. Manufacturer: NVIDIA Corporation. Installation success or error status: 0.

MSI © (D0:50) [01:22:30:430]: Grabbed execution mutex.
MSI © (D0:50) [01:22:30:430]: Cleaning up uninstalled install packages, if any exist
MSI © (D0:50) [01:22:30:430]: MainEngineThread is returning 0
=== Verbose logging stopped: 16.12.2017 1:22:30 ===

But when I am trying to install CUDA “cuda_9.1.85_windows” I get an error "Visual studio integration 9.1. failed(in Russian - сбой).