Cannot login into developer network to download "cudnn"

Hi,
I having trouble logging in to developer network even though I have an nvidia registered account. I am getting following error response.

“This account does not have an e-mail address associated with it. Please log in with a different provider”

Kindly help me with process.

In my case, I was trying to log by Chrome and I was receiving the same message. When I used Firefox, the the login worked.

Same as mayur.mahale with Chrome and IE.

I face to same problem too. But when I used Microsoft Edge, the login worked for me.

Same problewm here with Chrome, cannot download NCCL. Linux, so I cannot use Edge.

Chromium 66.0.3359.139 on Ubuntu 16.04: can’t login too.

It worked for me on Mozilla. I haven’t checked on IE & Edge.

same here, can’t download CudNN 7.0.5… I’m using chrome

https://developer.nvidia.com/compute/machine-learning/cudnn/secure/v7.0.5/prod/9.0_20171129/cudnn-9.0-windows10-x64-v7

I have been trying to login my account but nothing works… it always displays “this acccount does not have email address associated with it”… from 1 to 10 as 10 is the highest, i give them 4 for extremely bad user experience…

我也是一直無法登入 就算改過密碼也是一樣 可以處理一下嗎!

https://login.nvgs.nvidia.com/error