Cannot login to nvidia@DRIVE AGX

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.7.1.8928
other

Host Machine Version
native Ubuntu 18.04
other

After flashing the DRIVE AGX unit with DRIVE OS 5.2.6.0, we are no longer able to log in.
Could you please help us to resolve the issue? We cannot figure out what is the root cause.
Important information: we are not using SDKManager because we are using tailored version of DRIVE OS from NVIDIA.

Steps taken:

  1. LInux images compiled: make -f Makefile.bind BOARD=e3550b03-t194a PCT=linux clean
    make -f Makefile.bind BOARD=e3550b03-t194a PCT=linux
  2. Flashing from commandline finished with success: ./bootburn.sh -b e3550b03-t194a -B qspi --board_config …/board_configs/e3550b03-t194a.json
  3. Xavier A reset. Result:
  • problem during flashing Marvell Ethernet switch
  • login: ‘nvidia’ is rejected
         Starting One-time setup of security startup scripts...
[   21.289862] bash[1045]: Starting Marvell firmware checking...
[  OK  ] Reached target Graphical Interface.
         Starting Update UTMP about System Runlevel Changes...
[  OK  ] Started Update UTMP about System Runlevel Changes.
[   22.649398] bash[1045]: Marvell Ethernet update using config file /lib/firmware/marvell_ethernet//tools/linux/nvidia/E3550_Q5050.cfg
[   22.661277] bash[1045]: No arguments are provided, Only primary partition will be updated
[   22.666908] bash[1045]: --------------------------------------------------------------------
[   22.672711] bash[1045]: !!! IMPORTANT INFORMATION BELOW REGARDING Q5050 switch software update !!!
[   22.678667] bash[1045]: --------------------------------------------------------------------
[   22.684533] bash[1045]: !!! Q5050 Primary partition/s will be updated !!!
[   22.719276] bash[1045]: Reading firmware version from switch
[   22.723718] bash[1045]: ************ Idenfitying switch MAC address to be used ************
[   22.729168] bash[1045]: Using MAC 02-00-de-af-00-01 to get the firmware version

Ubuntu 18.04.5 LTS tegra-ubuntu ttyS0

tegra-ubuntu login: [   32.877440] bash[1045]: Switch did not repospond to MAC address 02-00-de-af-00-01
[   32.877922] bash[1045]: Get firmware version will be attempted using 02-00-00-00-00-11
[   43.017587] bash[1045]: Unable to get the current switch firmware version
[   43.018205] bash[1045]: Please also check the ethernet interface provided.
[   43.018458] bash[1045]: Current ethernet interface used is : eth0.200
[   43.018838] bash[1045]: Try running with sudo if not already
[   43.019242] bash[1045]: Could not get the current firware version.
[   43.019596] bash[1045]: Updation failed
[   43.020445] bash[1045]: ----------------------- Error log start ------------------------
[   43.021327] bash[1045]: /lib/firmware/marvell_ethernet//tools/linux/prebuilt/MarvFlashImage -fv -iieth0.200 -da02-00-de-af-00-01 -dn17 -th10000
[   43.022176] bash[1045]: Marvell 88Q5050 Image Download Tool v0.00.0014 (local build)
[   43.022518] bash[1045]: Result = 0
[   43.022879] bash[1045]: Start: 5430, current: 10006431, diff: 10001001, diff2: 10001
[   43.023300] bash[1045]: Timeout 10000 elapsed, RX tries: 5113586
[   43.023984] bash[1045]: TIMEOUT!
[   43.024818] bash[1045]: Failed to Get the response for firmware version get command :9807: ReceiveGetFwResponse()returned error 9.
[   43.025585] bash[1045]: GetFwVersion failed with error:9
[   43.025960] bash[1045]: Image Download Tool exiting with result 2.
[   43.026351] bash[1045]: /lib/firmware/marvell_ethernet//tools/linux/prebuilt/MarvFlashImage -fv -iieth0.200 -da02-00-00-00-00-11 -dn17 -th10000
[   43.026687] bash[1045]: Marvell 88Q5050 Image Download Tool v0.00.0014 (local build)
[   43.027037] bash[1045]: Result = 0
[   43.027424] bash[1045]: Start: 4898, current: 10005898, diff: 10001000, diff2: 10001
[   43.027784] bash[1045]: Timeout 10000 elapsed, RX tries: 5466446
[   43.028626] bash[1045]: TIMEOUT!
[   43.028966] bash[1045]: Failed to Get the response for firmware version get command :9807: ReceiveGetFwResponse()returned error 9.
[   43.029340] bash[1045]: GetFwVersion failed with error:9
[   43.030078] bash[1045]: Image Download Tool exiting with result 2.
[   43.030530] bash[1045]: ----------------------- Error log end ------------------------
[   43.031385] bash[1045]: Failed to update the Marvell switch firmware.. Script exited with 1

Ubuntu 18.04.5 LTS tegra-ubuntu ttyS0

tegra-ubuntu login: nvidia

Login incorrect
tegra-ubuntu login:

Hi, @sylwester.kocjan

Please see if How to do factory reset for both Xavier modules on DRIVE AGX? Drive OS reinstall at least does not change the nvidia password - #16 by user28207 and information on the topic help your problem. Thanks.

Hi @VickNV

This link was helpful, it helped us to restore the contents of /etc directory. Unfortunately, we have still issue with corrupted /usr/ directory, namely sudo, which is blocking our work.

Could you please let us know what can we do to make sure that entire filesystem is rewritten during flashing? I assume /usr is not a part of Persistent Partition.

Best regards,
Sylwester

Is the not-able-to-login issue fixed? If yes, please create another topic linked to this one for the current issue and elaborate it there.
BTW, this forum is for the releases in NVIDIA DRIVE Downloads | NVIDIA Developer so please make sure your issue is on one of the releases.

Hello @VickNV ,

The issue is fixed. Thank you for your support!