Cannot make my Quadro FX 4600 run with CUDA 1.1 or above

I have a Quadro FX4600 installed in a PC with windows XP.

  • I have installed the latest drivers for the card, CUDA 2.0 and CUDA SDK 2.0.
  • I can compile and run the examples from CUDA SDK 2.0 (the examples compile using default options for CUDA 1.0)
  1. When I run the CUDA SDK examples compiled with options corresponding to CUDA 1.1 or above, I get the
    “invalid device function” error.

  2. When I run the DeviceQuery program, it returns:

  • Major revision number: 1
  • Minor revision number: 0

I believe that Quadro FX4600 is compatible with CUDA 1.1 and above.
Anyone knows what I need to do to make it work with CUDA 1.1 or above?

Thanks,
David

Major/minor revision just have to do with the hardware, not the software. If you’re getting invalid device function everywhere, it’s likely that the drivers are not installed correctly.

I actually have the latest driver for this card (from Feb 2009) so I guess that is not it.

When talking about compiling with CUDA 1.1, I actually meant compiling with compute_11

As you can tell, I am pretty new to CUDA :)

I tried on some examples and get the following results when compiling with compute_11:

  • Debug mode => I get the “invalid device function”

  • EmuDebug mode => everything works

  • Release mode => no “invalid device function” but the output is incorrect.

Any idea?

If you’re compiling for compute_11, you can’t run that kernel on a compute 1.0 card.

I guess Quadro FX 4600 is only compute 1.0 capable, right?

Is there a document that lists compute capabilities for each graphic card?

Appendix A in the programming guide.