cannot open cudnn download page

i always get the page like below when i click download in

NVIDIA Developer Site is under going maintenance.
The site will be back by shortly.
We apologize for any inconvenience.

For technical questions, find answers and engage on our forums:

While you are waiting checkout the latest CUDA Blog at :

You may find driver downloads and other product information at

try again and make sure to reload the page or flush your browser cache.
I believe it is currently working/available.

When you click download, if you haven’t logged in, you should see a page that says “Membership Required” and asking you to log in.

same issue, i still can’t open that page now…

problem solved, flushing cache in chrome doesn’t work for me, but using microsoft edge instead works.
while in my linux mint 18, both firefox and opera(newly installed) don’t work…

I failed in entering the download page when using ms edge, but succeeded with IE. In ubuntu, failed with firefox and chromium. However, I get 502 error with IE now…

Same issue here, with Chrome and Firefox in Ubuntu 16.04.

I’ve been waiting for days expecting the maintenance will be finished, till I see this thread.

And finally I tried to login with Internet Explorer from Windows, the download links showed up.

tks #6, Win10 + Internet Explorer worked for me. Internet Explorer Edge still fail.

I tried chrome、edge、ie,no one work.
Maybe nvidia will release something new ?

I tried win10+IE. It works fine! Thank you so much. I have been struggled with this issue for days.

it works!thank you all.