CANNOT OPEN ON-BOARD CAMERA

I used JetPack3.1 to flash OS on my TX1. Today I tried to test the on-board camera by using the command “nvgstcapture-1.0”, however it returned:

** (nvgstcapture-1.0:2076): CRITICAL **: <create_capture_pipeline:4565> can't set camera to playing


** (nvgstcapture-1.0:2076): CRITICAL **: <main:5367> Capture Pipeline creation failed
** Message: <main:5374> Capture completed
** Message: <main:5424> Camera application will now exit

Next, I tried to open on-board camera by Cheese Webcom Booth, it warned “no device found”.
Could anyone instruct me how to open on-board camera?
Thanks a lot!

You may check https://devtalk.nvidia.com/default/topic/1028611/jetson-tx2/is-there-a-parameter-for-enable-disable-the-tx2-on-board-camera-/post/5232247/#5232247.

Thank you for your reply, but this link cannot solve my problem. I just cannot open the on-board camera, so I want to figure out whether this problem can be solved by setting the system.

I flashed TX1 by JetPack2.3 and I tried to open onboard camera again. At this time I success. Is this a software problem? In addition, I cannot run the example 09_camera_capture either.

It should work fine after flashing with JetPack3.1.
You may check your L4T R28.1 with:

sha1sum -c /etc/nv_tegra_release