cannot profile the application

Hi, I’m a student in the computer architecture lab, struggling with GPU profiling. I’m trying to use Nsight-Compute, but I have several problems. To practice how to use it, I’m now running really simple application that calculate the cube of whole elements in the global array, using CUDA kernel.

  1. ERR_NVGPUCTPERM
    In terms of this error, I’ve searched a lot and I think I’ve tried quite many things to solve it.
    First, I’ve executed the command

modprobe nvidia NVreg_RestirctProfilingToAdminUsers=0

and Second, I’ve wrote the line below in /etc/modprobe.d/cuda.conf

options nvidia “NVreg_RestirctProfilingToAdminUsers=0”

And they didn’t work

  1. The output file isn’t opened
    I think I cannot upload the image file here. Please refer the google drive link below. There are two image files
    https://drive.google.com/drive/folders/11EOEG-Q3QtrccWLMN7EYS6IpfMe-1NEt

The first thing I’m curious about is the Output File blank. Is this blank is the place for me to write the output file name arbitrarily? I’ve wrote it for me to notice which application this result is about.

The second thing is, if I’m right about this, why load error occurred? Is it just because that profiling has not been done because of Permission issue? Then, I have to solve the first problem I mentioned. But I don’t know how to do it. (I mentioned what I’ve done about this issue in 1))

  1. Command Line tab
    There are Command Line tab in my image file named ‘profile_option.png’. It is strange that it uses
    /opt/nvidia/nsight-compute/2019.4.0/target/linux-desktop-glibc_2_11_3-x64/nv-nsight-cu-cli

That is because, I ran that GUI with the command ‘nv-nsight-cu’ which is located in /usr/local/cuda-10.1/bin/ and there is also ‘nv-nsight-cu-cli’ in this location. Do you think is this a problem? There are not symbolic link between them. And the command in path under ‘/opt/’ is not what I’ve recently installed for CUDA profiling.

I’ve googled quite a lot about the keyword I’ve mentioned above. But I cannot find the right solution. Please help me :(

You can find details on how to resolve the ERR_NVGPUCTRPERM error here: https://developer.nvidia.com/nvidia-development-tools-solutions-ERR_NVGPUCTRPERM-permission-issue-performance-counters
Please follow the steps detailed on this page, and take note about the exact spelling of all the commands. The error and commands you listed here both have incorrect spelling, so the option wouldn’t be picked up by the driver.

On Linux, you can alternatively run the application with sudo privileges to solve the permissions issue.

If you don’t specify an output file, data will be recorded in a temporary file, which is discarded after printing the results on the CLI, or after closing the report in the UI. You can specify an output file name to save collected data on disk permanently for later analysis.

@felix_dt

The step that documentation informs is what I cannot do right now I think. That’s because I’m using this server with other lab colleagues. (I’m not a professional in using shared server.) However, referring that doc, I’m now using the tools well with ‘sudo’. Thank you very much.