Cannot resolve hosts

I managed to flash my Jetson TX2 on an Orbitty carrier board with the proper board support package after much trial and error. The method I used involved flashing from the BSP software itself with instructions to continue the installation of Cuda etc from JetPack after the fact. Unfortunately when I tried that the Jetson has difficulty connecting to specific ports and cannot do basic things like apt-get fails for example. I can ssh into the board, I can download the .deb directly from the board and install it, but when I do apt-get update it cannot resolve hosts and cannot download and install the rest of the toolkit that I need. I am extremely stuck here. When I first started I thought it was a problem with the network at the office as my computer was having issues with wifi so I connected the Jetson to a wired network which works but I still get the same errors. Any help would be much appreciated.

Assuming wired, what is the content of your “/etc/resolv.conf”? For the addresses within this, can you ping each? These are for DNS.

Can you do host lookups like “host”? One numeric address for is “”…can you ping that even if the “host” command fails?

Is the PC acting as router, or is there a router appliance?