Cannot revert to Opencl 1.0 level drivers after installing 1.1 preview Crashes at CLGetPlatformIDs

So I wanted to switch back over to the public drivers, since the 1.1 beta drivers are getting a bit old, and I was hoping to get rid of some stability issues and/or be able to upgrade to a 500 series card.

Problem is, I can’t get opencl to work at all on any other driver version besides 258.19_openCL1.1 whatsoever. I’ve tried the last 5 or so driver versions as well as the clean install option, as well as uninstalling the driver manually and reinstalling a different version, but nothing has worked. It always crashes in CLGetPlatformIDs, no matter what program I attempt to run. This applies both to all programs in the SDK as well as my own program.

Does anyone have any ideas how to repair this? I’m running Win 7 64bit.

Do you also have ATI drivers installed by any chance? Because I have the same issue when swapping GPUs for benchmarking an keeping the Catalyst driver files on the system while an NVIDIA GPU is installed. In any case, I’d recommend running Driver Sweeper to remove all drivers that should not be there and do an NVIDIA driver installation using the “clean install” option.

Got rid of lingering ATI drivers, did a clean install, and… nothing. Still crashes.

Clearly there’s something that’s not getting cleared, but I have no idea what that would be…

Check the registry path at


and see if it still contains entries for the ATI OpenCL ICDs (“atiocl.dll”, “atiocl64.dll”). If so, rename or remove them, and see if that helps.

Yep, that fixed it, thanks :-)