Cannot run CloudXR Windows client with localhost (i.e., same PC as the server)

I tried to run the windows client connecting to localhost as a local testing with the server, but the connection seems cannot be established. I saw there is error “Client requested HEVC, which is not supported.” in the server log, but I can confirm that my GPU supports HEVC, and both client and server are running on the Nvidia GPU (I use a laptop). Also, in the server log it also says “Device ‘’ does not support HEVC.”, where the device name is left blank. However, at the beginning of the server log, my GPU name is correctly identified as “FriendlyName=NVIDIA GeForce GTX 1650 with Max-Q Design”.

Also in the client log it says “ERROR: Malformed or missing stop data with size: 0.”

I speculate that this might be because both the server and client need to use the NvEnc interface so it conflicts? The server works well with a Quest 2 client, as it request H.264 from the server. However, the windows client requests HEVC, which is “not supported” by my server, says in the log.

Any help is welcome!
Thanks in advance!

Someone else may chime in here, but I recall something about the original 1650 boards using an older NVENC engine (while the 1650 Super and 1660 used newer one). The fact you note you are getting h264 by default is already a red flag, as while that support is in the streaming library under the hood, we don’t officially support it. So it might be the graphics card is simply the issue here.

Thanks a lot! I think that is the issue as I changed to a 2080 ti laptop and it works well!

glad to hear that worked. @wcannady we should definitely document this tidbit in Requirements somewhere, if you want to open a task to track.

I’m going to close this topic out as answered and working.