Cannot run deepstream6.1 usbcam example on jetson xavier

Hi. I am trying to set up development environment using deepstream-l4t image.

I am using jetson xavier.

On my xavier, I down load ‘nvcr.io/nvidia/deepstream-l4t:6.1-samples’.

And I install python binding. (https://github.com/NVIDIA-AI-IOT/deepstream_python_apps#sample-applications)

After I succeed install python bindings, I ran ‘python deepstream_test_1_usb.py’, a sample app.

Then I got below error:

Creating Pipeline 
 
Creating Source 
 
Creating Video Converter 

 Unable to create pgie 
 Unable to create nvosd 
Creating EGLSink 

Playing cam /dev/video0 
Traceback (most recent call last):
  File "deepstream_test_1_usb.py", line 283, in <module>
    sys.exit(main(sys.argv))
  File "deepstream_test_1_usb.py", line 214, in main
    pgie.set_property('config-file-path', "dstest1_pgie_config.txt")
AttributeError: 'NoneType' object has no attribute 'set_property'

Can you help me?

Two more questions.

  1. Can I use deepstream 6.1 on ubuntu 18.04?
    because some example like this link make me confuse like deepstream6.1 is only available on ubuntu 20.04.

  2. Can you let me know nvidia container runtime-deepstream version compatibility?

Thanks.

versions:
xavier host os version( Linux nvidia-desktop 4.9.253-tegra):
NAME=“Ubuntu”
VERSION=“18.04.5 LTS (Bionic Beaver)”
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME=“Ubuntu 18.04.5 LTS”
VERSION_ID=“18.04”
HOME_URL=“https://www.ubuntu.com/
SUPPORT_URL=“https://help.ubuntu.com/
BUG_REPORT_URL=“https://bugs.launchpad.net/ubuntu/
PRIVACY_POLICY_URL=“https://www.ubuntu.com/legal/terms-and-policies/privacy-policy
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic

Unable to create pgie
Unable to create nvosd
Can you find these plugins?
You can not run deepstream 6.1 on ubuntu 18.04. you can use docker to escape this dependency.

I cannot find those plugins. This is the curious part because I down load ‘nvcr.io/nvidia/deepstream-l4t:6.1-samples’ image. Isn’t this image supposed to have the forementioned plugins?

If not, how to install those plugins?


From deepstream6.1 document I found below. should I install it on host? (because I still have same problem I mentioned above after I installed dependecies and kafka in docker container)

1. Install Dependencies

Enter the following commands to install the prerequisite packages:

$ sudo apt install \
libssl1.1 \
libgstreamer1.0-0 \
gstreamer1.0-tools \
gstreamer1.0-plugins-good \
gstreamer1.0-plugins-bad \
gstreamer1.0-plugins-ugly \
gstreamer1.0-libav \
libgstrtspserver-1.0-0 \
libjansson4 \
libyaml-cpp-dev

2. install kafka

How about result gst-inspect-1.0 nvinfer

I solved my issue by downloading deepstream6.0 docker image and installing missing gstreamer libraries.

It seems I must setup my jetson using Jetpack 5.0.1 DP.
So deepstream6.1 docker image is not compatible with Jetson OS that is installed by previous Jetpack version.

Please use compatible Jetpack and Deepstream version.
https://docs.nvidia.com/metropolis/deepstream/dev-guide/text/DS_Quickstart.html#platform-and-os-compatibility

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.