Cannot run samples in Host

Please provide the following info:
**Hardware Platform: DRIVE AGX Xavier™ Developer Kit
**Software Version: DRIVE Software 10
**Host Machine Version: native Ubuntu 18.04
**SDK Manager Version:

I have successfully installed host and target version. And I can run the sample out of the box in target. But once i tried this …/DRIVE_SW_10.0_References/DRIVE_Software/DRIVE_AV_doxy_files/dwx_verification.html - to verify my installation I can see the folder structure intact - but once I try running ./sample_drivenet - I cannot able to run the sample with the following error be the obstruction:

./sample_drivenet: error while loading shared libraries: cannot open shared object file: No such file or directory

In addition: I was actually trying to cross compile our own dw_api but left with many errors as attached in the log file. log_cc_fail.txt (126.2 KB)
Kindly help solving this

Dear @bkumar1,
You need mimimum PASCAL based GPU and need to install Nvidia graphics drivers to run drivenet and other samples. Please check Nvidia Drive Software 10.0(Linux) : missing and

1 Like

Thanks Siva! I have installed and now it is throwing this error:

(base) nvidia@nvidia:/usr/local/driveworks/bin$ ./sample_drivenet
terminate called after throwing an instance of ‘std::runtime_error’
what(): [2020-06-26 18:54:38] CUDA Error CUDA driver version is insufficient for CUDA runtime version executing CUDA function:
cudaStreamCreateWithFlags(&m_cudaStream, cudaStreamNonBlocking)
at /dvs/git/dirty/gitlab-master_av/dw/sdk/samples/drivenet/drivenet/main.cpp:142
Aborted (core dumped)

I tried other samples still runtime error.

This is for hello_word:

(base) nvidia@nvidia:/usr/local/driveworks/bin$ ./sample_hello_world

Welcome to Driveworks SDK
[26-06-2020 19:06:48] Platform: Detected Generic x86 Platform
[26-06-2020 19:06:48] TimeSource: monotonic epoch time offset is 1593190059559360
[26-06-2020 19:06:48] Driveworks exception thrown: Platform: cannot acquire CUDA context, error cudaErrorInsufficientDriver: CUDA driver version is insufficient for CUDA runtime version

Cannot init SDK

And this is my graphics : Nvidia GP104GL (quadro P4000) and the driver is 435 (proprietary, tested)

Dear @bkumar1,
It can be seen from that CUDA 10.2 requires minimum 440.33 drive version. Please update driver version and check running

1 Like

Dear @SivaRamaKrishnaNV, I have installed 450 drive version and now i can run samples in the host. Thank you for your prompt replies.
But I now have problems compiling build-x86 in the sample folder which i am creating inside my host directory by linking the driveworks samples.

I will post as a new thread and for now I will end this thread to enable clear history for those who may refer in future. Thank you!