Cannot run two screens with quadro 2000

I am trying to set up 2 monitors in 2 screens (one monitor has 10bit capability so I want to run 2 screens). The first monitor appears fine but not the second one – it remains black. nvidia-settings seems to recognize both monitors and screens, but if I try “Save to X Configuration File”, a pop-up appears saying “Multiple X screens are set to absolute positioning […] one or more X screens may be […] unreachable”. Within /etc/X11/xorg.conf.d/20-nvidia.conf I’ve tried setting “Screen1” RightOf “Screen0” as well as “Screen1” Relative “Screen0” 2560 0 but nothing changes. Any suggestions?
nvidia-bug-report.log.gz (168 KB)

“Screen1” RightOf “Screen0” should be correct. No idea why nvidia-settings complains.
The second screen is probably black because nothing runs on it. Try
DISPLAY=:0.1 xterm
and check if it opens. Can you move the mouse to it?

Thank you. I went back to “Screen1” RightOf “Screen0”.
When I run
DISPLAY=:0.1 leafpad
no error is posted but the second monitor remains black, I if try to move my mouse in it nothing shows. (note that DISPLAY=:0.0 leafpad does start leafpad on my main monitor).

I am assuming the quadro 2000 can run two monitors with 2560x1440 and 1920x1200 (confirmed by chatting with nvidia support).

[  2796.873] (II) NVIDIA(0): Display device(s) assigned to X screen 0:
[  2796.873] (II) NVIDIA(0):   CRT-0
[  2796.873] (II) NVIDIA(0):   DFP-0
[  2796.873] (II) NVIDIA(0):   DFP-1
[  2796.873] (II) NVIDIA(0):   DFP-2
[  2796.873] (II) NVIDIA(0):   NEC PA271Q (DFP-4)
[  2796.874] (II) NVIDIA(0): Virtual screen size determined to be 2560 x 1440

[  2796.920] (II) NVIDIA(1): Display device(s) assigned to X screen 1:
[  2796.920] (II) NVIDIA(1):   Ancor Communications Inc PA248 (DFP-3)
[  2796.921] (II) NVIDIA(1): Virtual screen size determined to be 1920 x 1200

According to the logs, everything seems fine. At least I can’t spot anything.
Please post the output of
DISPLAY=:0.1 xrandr

$ DISPLAY=:0.1 xrandr
Screen 1: minimum 8 x 8, current 1920 x 1200, maximum 16384 x 16384
DP-0 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 546mm x 352mm
1920x1200 59.95*+
1920x1080 60.00
1680x1050 59.95
1600x1200 60.00
1440x900 59.89
1280x1024 75.02 60.02
1280x960 60.00
1152x864 75.00
1024x768 75.03 70.07 60.00
800x600 75.00 72.19 60.32 56.25
640x480 75.00 72.81 59.94

I’ve also been checking connections and cables. Switching cables yields same result. The only thing that changes is pluggint the 2nd monitor (Asus, screen1) with its DVI connection (instead of DisplayPort) to the 2nd DisplayPort of the quadro (through an adapter). Then I can move the mouse on the second monitor, but the cursor takes on “X” shape rather than arrow. I can open an application on the second monitor, if I hover with the mouse I can see various menu items but not interact fully with them. In all cases though, keyboard input stays on screen0: if I open a terminal on screen1 and start typing, the typing is displayed on screen0.

More research: I am thinking the problem lies with my configuration of OpenBox / LXDM. OpenBox docs say I must start a distinct openbox session on the second display. I’m looking into how I could do that, and will report if I find a solution. That still does not explain the difference with using DVI rather than DP on the monitor, but if I can make it work that won’t matter. Thank you!

Of course only the first screen will be used by default, on the second you’ll have to run something by e.g. creating an autostart
DISPLAY=:0.1 openbox &
That doesn’t explain why mouse and keyboard are not properly functioning, that should be independent of any WM, it’s still the same Xserver.
The problem with it only working when connected over DVI is rather weird.

“Of course”? Not really, this is the first time I’ve attempted this :). I’ve tried including

DISPLAY=:0.1 openbox &
exec openbox-session

in ~/.xprofile, so that lxdm will source it. On the second screen I now get a normal cursor, I can start a terminal from the OpenBox menu, write into it. However if I move the terminal window “traces” of the window are left displayed, if I close the window (exit, or clicking on button on window border) it is no longer active (I cannot write into it) but it does not disappear.

So I will keep on investigating, to see what the proper way is (if any) to have two screens with openbox/lxdm…

Thanks.