Cannot turn on camera on Jetson Nano 4GB

Could you check the v4l2-ctl command after change the connector.

I just typed this command " v4l2-ctl --stream-mmap --set-ctrl bypass_mode=0" and terminal response nothing as follow.

What’s the kernel message after this command?

it shows nothing, just cursor keep blanking

I mean the kernel message by dmesg

It shows nothing

It’s very weird !
Even no camera is connected to Jetson, dmesg has some imx219 related logs like this.
It’s same when camera module is out or order.

jetson@jetson-desktop:~$ dmesg | grep imx219
[    1.264319] imx219 6-0010: tegracam sensor driver:imx219_v2.0.6
[    1.287658] imx219 6-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.287685] imx219 6-0010: board setup failed
[    1.287748] imx219: probe of 6-0010 failed with error -121
jetson@jetson-desktop:~$ cat /etc/nv_tegra_release 
# R32 (release), REVISION: 4.3, GCID: 21589087, BOARD: t210ref, EABI: aarch64, DATE: Fri Jun 26 04:38:25 UTC 2020

I reflashed the jetson nano and have jetson inferenced installed. I then followed the instructions on jetson-inference/docs/ aux-streaming.md and still cannot get camera turned on?
I typed video-viewer csi://0
for CAM1 slot jetson nano crashed and reboot itself
for CAM2 slot terminal return the message of view-viewer: failed to capture video frame
[gst_mini_object_set_qdata: assertion ‘object != NULL’ failed Eror]

Hi @wi072815, are you sure the camera’s ribbon cable is installed into the header port in the correct orientation? The contacts of the cable should face inwards towards the module like here:


Also, try seeing if nvgstcapture-1.0 program can view the camera stream.


Yes is installed in the correct orientation

Sorry for keep posting!
I ran video-viewer from jetson-inference with command video-viewer csi://0
and I get this message

Hi,
I am an beginner I recently purchased Jetson Nano 4GB kit and Imx 219-120 have similar Error coming tried to swap the ports and re flashed but still the same during booting there is this message (imx219_board_setup: error during i2c read probe (-121)).

Regards
Mukesh Khokle

1 Like

@wi072815, @mukeshdkhokle

Would you try this simple example?

BTW, you’d better change the camera module.
I recently got DoA.