Cannot use CSI Camera after downgrading Jetpack

I have a Jetson NX running Jetpack 4.6 and was configured to use 2 IMX477 cams.
But for a project specific reason I need to downgrade the Jetpack to 4.5 so I swapped the SD card to a Jetpack 4.5 version. The CSI cameras are visible but I cannot start any pipelines. Even a simple gst-launch command fails with the error:

Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:645 No cameras available

(gst-launch-1.0:8754): GStreamer-CRITICAL **: 18:27:40.127: gst_mini_object_set_qdata: assertion 'object != NULL' failed
Got EOS from element "pipeline0".
Execution ended after 0:00:00.043345344
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...
(Argus) Error EndOfFile: Unexpected error in reading socket (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 266)
(Argus) Error EndOfFile: Receive worker failure, notifying 1 waiting threads (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 340)
(Argus) Error InvalidState: Argus client is exiting with 1 outstanding client threads (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 357)
(Argus) Error EndOfFile: Receiving thread terminated with error (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadWrapper(), line 368)
(Argus) Error EndOfFile: Client thread received an error from socket (in src/rpc/socket/client/ClientSocketManager.cpp, function send(), line 145)
(Argus) Error EndOfFile:  (propagating from src/rpc/socket/client/SocketClientDispatch.cpp, function dispatch(), line 87)

The launch command
gst-launch-1.0 nvarguscamerasrc ! fakesink

Device List

ls -l /dev/video*

crw-rw----+ 1 root video 81, 0 Sep 27 18:19 /dev/video0
crw-rw----+ 1 root video 81, 3 Sep 27 18:19 /dev/video1

I have tried this with 3 different NXs and same issue happens. Is there any extra setting persisted on board?
Note that the SD Card with Jetpack 4.5 is cloned from an NX which is working in JP4.5 setup and not flashed from scratch.
I have also tried to reinstall the arducam drivers.


hello marmikshah,

did you simply swap the sdcard with JP-4.5, but the platform is actually flashed with JP-4.6?
here’s rollback protection and it also had dependencies with kernel and kernel-dtb binaries.

instead of downgrading Jetpack, you should flash pure JP-4.5 for confirmation,

Thanks for you reply. Yes I simply swapped the SD Card as that SD was originally used on the same NX before I flashed a new SD card with JP4.6 for this NX.
So does this mean that there are some settings persisted in the board causing this?

I will try to flash JP4.5 and try.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.