Cannot use nVidia GPU in laptop with two video cards

Hello,

My first post here, as I normally find solutions by searching already answered posts.

I have a dell latitude E6420 and it comes with an Intel gpu connected to the LCD and an Nvidia quadro connected to the Hdmi port.

When I boot Ubuntu 12.04 with no Xorg.conf file, X detects the intel one and the LCD works properly - but the Nvidia board is not detected and don’t even listed on XrandR.
The distro drivers are installed properly (they seem to be, at least), but running ‘nvidia-xconfig’ creates a buggy xorg.conf that makes both gpu’s unusable.
After making many experiments I came with a xorg.conf that allows the intel+LCD work while apparently loading the GFX from nvidia.
But the quadro gpu is still not working.

Well, you can see in the https://docs.google.com/file/d/0BxF1aA08GvRxQlV0M0NnSW9BV00/edit nvidia-bug-report.log.gz the X log and the conf file created.
Also, opengl is not working on the intel gpu with the nvidia drivers installed.

Your xorg.conf file has two device and screen sections in it, but only one of them is named in the Layout section so only the Intel device will have an X screen on it. To add the other one, you probably want something like

Screen 1 "Screen1" RightOf "Screen0"

in the ServerLayout section.

You are most likely using NVIDIA OPTIMUS. Right now NVIDIA doesn’t have optimus support, but they are working on it(I think that aplattner recently pushed some patches to the kerner for dma_buf). That doesn’t mean that you can’t use the card. There is a community solution named Bumblebee Project. Here is the link to github:
https://github.com/Bumblebee-Project/Bumblebee
Of course there is a PPA for it that will save you from compiling the code:
https://launchpad.net/~bumblebee/+archive/stable
After you read the readme and wiki for bumblebee you will know about optirun. There is a faster solution that it called primus. Here is github link to it:
https://github.com/amonakov/primus
and a PPA:
https://launchpad.net/~zhurikhin/+archive/primus

I hope this will help you.

@Aaron - you’re right, but I need to fix the driver issues first.

@ytsolov - Indeed, I’ve entered in the bios after reading what ‘optimus’ is and it was there, enabled.

I’ve installed bumblebee and GLX graphics are fine now - running ‘optirun spheres’ does make a pretty fast smooth graphics.

Still, hdmi is not being detected - nvidia-settings complains stating ‘…not appear to be using the NVIDIA X driver’.
I’ve somehow lost ‘nvidia-xconfig’ - so I’ll kepp editing xorg.conf by hand.
This laptop is laughing at me…

thanks folks.

nvidia-xconfig should be /usr/lib/nvidia-current/bin, where nvidia-current is the nvidia package that you installed.

nvidia-xconfig is there indeed, but the generated xorg.conf is very buggy - no graphics at all, i needet to boot in CLI to delete the conf. file

I now discovered that using an adapter I can connect the VGA output of the laptop to the DVI input of the monitor (it only has DVI and HDMI), so I can use it.

The hdmi is still dead - I’ve tried using a separate X session with DISPLAT=:8.0, as seen in another post, but the X session runs in some unknown display, not hdmi.

I’ll wait for a next release of Nvidia drivers for linux and keep on vga for now.