Cannot use "save as" with latest machinima

sorry to tell but “file/save as” command never finnish the scene.

old versions of machinima crashed too on this, but the file was always created anyway.

Create can make the file :)

Hi @pekka.varis! I let the Machinima team know about this problem. Do you happen to have any logs that you can add to help troubleshoot this issue?

  • Omniverse Logs: C:\Users\<USERNAME>\.nvidia-omniverse\logs

  • Connector Logs: C:\Users\<USERNAME>\Documents\Omniverse\<CONNECTORNAME>

Repro steps here could seriously help us track down what you’re seeing @pekka.varis . Sometimes specific data can cause issues. Machinima loads several extensions that Create does not, so could be some interaction in those.

Here is a fresh log file from

omni.kit.logging.log (146.6 KB)

It has been created when Machinima tried to save the scene.
Btw I tried the save as command on a fresh empty scene with some primitive meshes I made in Machinima and save as works there just ok.

So it must be from fact that this scene is made with older versions of Machinima and connectors. If you want to have the full scene then give a PM to me with email and I can send you the scene & assets.

1 Like

After looking at it Pekka I was able to do a File->Save As myself with the current shipped version of Machinima, but I had to place the entire project in a very short path name. It seems the bug is that long path names can sometimes cause problems with Machinima. Can you try to see if you can shorten some of the longest path names in the project and see for yourself if that allows you to save-as? You could also try moving the project to a very short path, such as C:\House\ but that is just a stop-gap measure.

I have bugged this issue and we will get it fixed, I am just suggesting some workarounds you can try.

1 Like

Thanks, I tried this but it keeps crashing while saving and only 1 KB file is made, so same as before. Maybe the file folder names are just too long inside the “collected assets” folder.

Here are my logs from the time of “saving as” was running:

launcher.log (638.9 KB)
omni.kit.log (74.2 KB)
omni.kit.logging.log (1.3 MB)
omni.processlifetime.log (120.1 KB)
omni.telemetry.transmitter.log (107 Bytes)
(omni.telemetry.transmitter.exit was 0 KB)

Relam, FYI: