Can't access Fan - Jetpack 4.2 Development board and Auvidea J120 board

Since I installed Jetpack 4.2 along with the Auvidea J120 Kernel patches for the JP4.2 version, the fan is not working correctly.

  1. Jetson TX2 mounted on the development board:
    Fan does not turn on when I execute
sudo jetson_clocks

I am getting the error “cant access fan” and the TX2 gets unreasonable hot when I execute heavy load applications like mesh generation with a ZED camera.

  1. Jetson TX2 mounted on a Auvidea J120 board:
    Fan is always on when I boot the TX2, independent from executing jetson_clocks or changing the power mode.

Also in this case I am getting the error “cant access fan!” when I try to run jetson_clocks:

apsync@apsync:~/Github/companion/Nvidia_JTX2_JP42/Ubuntu$ sudo jetson_clocks --show
SOC family:tegra186  Machine:quill
Online CPUs: 0-5
CPU Cluster Switching: Disabled
cpu0: Online=1 Governor=schedutil MinFreq=2035200 MaxFreq=2035200 CurrentFreq=2035200 IdleStates: C1=0 c7=0 
cpu1: Online=1 Governor=schedutil MinFreq=2035200 MaxFreq=2035200 CurrentFreq=2035200 IdleStates: C1=0 c6=0 c7=0 
cpu2: Online=1 Governor=schedutil MinFreq=2035200 MaxFreq=2035200 CurrentFreq=2035200 IdleStates: C1=0 c6=0 c7=0 
cpu3: Online=1 Governor=schedutil MinFreq=2035200 MaxFreq=2035200 CurrentFreq=2035200 IdleStates: C1=0 c7=0 
cpu4: Online=1 Governor=schedutil MinFreq=2035200 MaxFreq=2035200 CurrentFreq=2035200 IdleStates: C1=0 c7=0 
cpu5: Online=1 Governor=schedutil MinFreq=2035200 MaxFreq=2035200 CurrentFreq=2035200 IdleStates: C1=0 c7=0 
GPU MinFreq=1300500000 MaxFreq=1300500000 CurrentFreq=1300500000
EMC MinFreq=40800000 MaxFreq=1866000000 CurrentFreq=1866000000 FreqOverride=1
Can't access Fan!
NV Power Mode: MAXN

Any idea how I can get the fan working properly on the J120 and/or dev board?

Fans would depend on device tree. Did you also install the Auvidea board support package device tree changes? Sorry, I’ve not worked on other carrier boards, but this would be a necessary step for the fan to show up correctly (beyond kernel changes).

Thanks for getting back. Yes I have the latest Auvidea 2.0 firmware for Jetpack 4.2 installed.

There may be an error with the Auvidea firmware. Basically, the content in “/sys” is an interface to various drivers. The BSP would be needed for the driver to actually connect to the fan. If the driver doesn’t load (and it probably does since the system otherwise boots), then the reason for absence of that “/sys” file is because the driver didn’t find any fan hardware.

There are many times when the fan would be stopped, but the file actually missing is a bit of a “smoking gun” evidence. You may have to ask Auvidea about the fan support and whether the BSP is missing something.

I talked to Auvidea support in the meantime. They confirmed that the fan control doesn’t work with the J120 Rev 8 board along with Jetpack 4.2 onwards. Therefore with the latest Auvidea firmware, the fan is always turned on.

Question: is there a way that I can modify jetson_clocks so that fan access is no longer checked?
Since the fan is always running, there is no need to check it.

I am having the same issue and to go even further on jetpack 4.2 when I trying running sudo jetson_clocks it gives me the message in the terminal and then it immediately shuts down my TX2? What could be happening this has to be unrelated to the actual fan and kernel issue?

No clue why it crashes. I just get the error message that the fan cannot be accessed.
I found a way to enable jetson_clocks now by using this tool:

FYI, “jetson_clocks” is just a human readable bash script. You can examine this, modify it (or modify a copy), so on. If there is an immediate shutdown, then you probably need to get a log on the serial console (e.g., run “dmesg --follow” on the serial console).

Yes I will try that but in the meantime I’ve found that this lets you set the nvpmodel in a more streamlined way for the jetson and allows you to monitor the clocks and gpu.