Can't access RTSP on my local network using deepstream-app

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
AGX Xavier

• DeepStream Version
Deepstream 6.2

• JetPack Version (valid for Jetson only)

• TensorRT Version

• NVIDIA GPU Driver Version (valid for GPU only)

• Issue Type( questions, new requirements, bugs)
I can’t get an RTSP feed to work. I have RTSP running as my sink, and the deepstream-app shows it running on localhost ( *** DeepStream: Launched RTSP Streaming at rtsp://localhost:8554/ds-test ***). I show FPS of my inference. Yet when I try to connect to the stream over my LAN using the Jetson’s IP address (rtsp://, VLC is unable to open the stream. The log file says:

  • logger module started –
    main: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
    main: playlist is empty
    satip error: Failed to setup RTSP session

NMAP shows the port is open, and I’m running this on a barebones switch with no filtering or customizations at all. I am SSH’d into the Jetson from the laptop where I’m trying to view the stream.

Here’s my source and sink config:



I can’t think of anything else. I’ve searched and searched the forums and see other similar posts, most of which say “check your network settings.” My network settings are as basic as possible.

Any ideas? I just need to see the stream on my laptop, nothing fancy.

• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
See notes above.
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Have you tried switching software encoder?

Modify value of enc-type to 1

I have tried your configuration file on my Jetson, It work normal.


The above configurations should be invalid

@junshengy I recognize some of my configuration items are unnecessary, but thanks for pointing it out.

Switching enc-type didn't fix it.

Might I ask what program you are using to view RTSP streams? I ask because I just discovered that I can get it to work on mplayer, but not VLC.

For the benefit of the next weary traveller who runs into a similar issue, the following is some of what was printed after running mplayer:

**player rtsp://**
**MPlayer 1.4 (Debian), built with gcc-11 (C) 2000-2019 MPlayer Team**
**do_connect: could not connect to socket**
**connect: No such file or directory**
**Failed to open LIRC support. You will not be able to use your remote control.**

**Playing rtsp://**
**Resolving for AF_INET6...**

**Couldn't resolve name for AF_INET6:**
**Connecting to server[]: 8554...**

**librtsp: server responds: 'RTSP/1.0 503 Service Unavailable'**
**rtsp_session: unsupported RTSP server. Server type is 'GStreamer RTSP server'.**
**libavformat version 58.76.100 (external)**
**libavformat file format detected.**
**[lavf] stream 0: video (h264), -vid 0**
**VIDEO:  [H264]  1920x1080  0bpp  4.000 fps    0.0 kbps ( 0.0 kbyte/s)**
**X11 error: BadMatch (invalid parameter attributes)**
**Failed to open VDPAU backend cannot open shared object file: No such file or directory**
**[vdpau] Error when calling vdp_device_create_x11: 1**
**Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family**
**libavcodec version 58.134.100 (external)**
**Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)**
**Clip info:**
** title: Session streamed with GStreamer**
** comment: rtsp-server**
**Audio: no sound**
**Starting playback...**
**Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.**
**VO: [xv] 1920x1080 => 1920x1080 Planar YV12 **
**V:  14.3   0/  0  4%  0%  0.0% 0 0 **
**[rtsp @ 0x7f702606f8e0]max delay reached. need to consume packet**
**[rtsp @ 0x7f702606f8e0]RTP: missed 70 packets**
**V:  14.8   0/  0  4%  0%  0.0% 0 0 **
**[h264 @ 0x7f70255db380]co located POCs unavailable**
**[h264 @ 0x7f70255db380]mmco: unref short failure**
**V:  17.2   0/  0  3%  0%  0.0% 0 0 **
**[h264 @ 0x7f70255db380]co located POCs unavailable**
**V:  19.7   0/  0  3%  0%  0.0% 0 0**

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

I tested ffplay and vlc on different computers, both can work normally.

Have you tried to update or reinstall vlc?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.