Can't auto login on R32.4.4 ubuntu

Hi,

I’m working on TX2 R32.4.4.
I have enabled auto login option, but it still can’t login automatically.
Any one can help?

Thx
Yen

Hi,

Due to the law, we won’t provide auto-login or built-in user account on device anymore.

Hi kayccc,

My question is I have created a username/password at the first bootup, and also enable autologin option at the same page.
It will auto reboot and auto login after creating username/password.
So far, everything goes well.(second bootup)

From 3rd bootup, ubuntu start asking password.
This is issue I am asking for help.
Are you sure this is the same condition as you mentioned?

Thx
Yen

Hi Yen,

I don’t get your problem. Is this problem on monitor or serial console??

Hi,

It is on monitor, not console.

Thx
Yen

Does this issue only happen to 32.4.4?

Yes

Hi yenchao,

The automatic login is working on r32.4.4.
Please check you are enable automatic login from:
All Settings -> User Accounts -> Turn “ON” Automatic Login.

Hi,

I use the original Linux_for_Tegra and rootfs to flash again and it works now.
But I still don’t know why.

Anyway, thanks for your guys quick help.

Thx
Yen

1 Like

Hi carolyuu,

I did some test on this issue.

  1. Original Linux_for_Tegra works fine.
  2. I followed your document “NVIDIA Jetson Linux Developer Guide->Building the NVIDIA Kernel” to build the original kernel image, after the following step, the OS won’t auto login(figure below).

7.Execute the following commands to install the kernel modules:
$ sudo make ARCH=arm64 O=$TEGRA_KERNEL_OUT modules_install
INSTALL_MOD_PATH=/Linux_for_Tegra/rootfs/

Could you confirm if you have the same issue after doing the same step as mine.

Thx
Yen

Hi yenchao,

After you replace kernel Image and install kernel modules, then full flash. You need setup auto login again.

Hi carolyuu,

So you mean after create a username/password at the first bootup, I need to set auto login again in " All Settings -> User Accounts -> Turn “ON” Automatic Login." when I enter ubuntu at the first time?

Thx
Yen

Hi yenchao,

For first time boot, after you finish the setup process, system can auto boot into Desktop GUI.
You can also select auto login options in first setup username/password page.

Hi carolyuu,

That’s right! (I define this as second time boot)

I already did this in setup process at the first time boot .

But it showed this image after I reboot ubuntu(third time boot)

Thx
Yen

Hi yenchao,

Are you means you already select auto login options in first setup process and confirmed “All Settings -> User Accounts -> Turn “ON” Automatic Login” setting, then the second boot still in login screen?

If yes, please show me below information:
$ cat /etc/gdm3/custom.conf

Hi,

The configuration I set.

It shows login screen at third boot.
Please see the information as follows

p@p-desktop:~$ cat /etc/gdm3/custom.conf

GDM configuration storage

See /usr/share/gdm/gdm.schemas for a list of available options.

[daemon]
AutomaticLoginEnable=true
AutomaticLogin=p

Uncoment the line below to force the login screen to use Xorg

WaylandEnable=false

Enabling automatic login

Enabling timed login

TimedLoginEnable = true

TimedLogin = user1

TimedLoginDelay = 10

[security]

[xdmcp]

[chooser]

[debug]

Uncomment the line below to turn on debugging

More verbose logs

Additionally lets the X server dump core if it crashes

#Enable=true

p@p-desktop:~$

Hi,

Please copy the nvgpu.ko from original jetpack driver package and use it to replace the one build from you.

Check if that can work.

Hi WayneWWW,

I have tried your suggestion, but the issue still exist.

Thx
Yen

  1. please check if the disk space is still sufficient

  2. please show us the size of nvgpu.ko.

  3. please check which part is causing this issue. The kernel image or the modules.

Hi WayneWWW,

Sorry, I made a mistake, it works now.
May I know why the nvgpu.ko I built can’t auto login?

Thx
Yen