Can't boot Jetson Nano

Hey. So, I’m pretty new in moving along with Linux System and Jetson Nano, and i was here doing some stuff for a project, and i removed the python files (im not sure if this is the error because I dont think I deleted python2.7, only 3.6 and I think I had both, not sure tho). Now, when I login, it appears to login in my account, I write the password and shows "unable to launch “/usr/bin/startlxde” X session … ". I dont know how to open the terminal from the login menu, I saw some texts saying that it was CTRL + ALT +F1 (or all those F’s until F12) and nothing happens. Can anyone help me? Thanks!

Is it jetson nano 2gb? If the terminal does not show up on HDMI monitor after you use keyboard to type ctrl+alt + F2, then please use below method to dump the log from uart.

Isn’t there a way to do it without another computer? I’m using headless mode

Is the ethernet still alive and you happen to know the IP address?

I think so but it’s not possible for me to check because im just stuck in the login menu. I write the password then appears what I said above.

yes, that was why I asked you to use uart console. You are out of methods to access it on device directly.

BTW, the definition of “headless” should be there is no monitor connected on your device. But not a no host case.

Also, could you make a video for what is exact happens here? I am not pretty sure why ctrl+alt +F2 does not take effect.

There you go. WHen I CTRL ALT F2 nothing happens.

Is this a jetson nano 2gb device ? BTW, your video is blurred here so I can only see the ctrl + alt + F2 does not move to tty console. I cannot see anything clear from the screen.

This will be helpful for you. This is some recent bug in nano platform
The problem can be fixed by following the instructions in this link below.

1 Like

Hi @Aravind_Seenu,

Thanks for sharing this. But what I am wondering is how did you hit this problem and why your solution is using lxde?

Everything was fine. All of the sudden when system was powered back it showed this screen. “unable to start…”

I had experience of this desktop issue in kali linux platform. So I tried reinstalling the desktop and got it fixed.

The problem is recent in nano platforms. It might be due to certain updates in ubuntu platform. I am not sure.

1 Like

Even I am wondering. About the issue Everything was fine. I shut it down and next day when I booted it back this issue appeared.

So no idea how this problem came, but I was able to fix this but following the stated procedures.


Just want to know the first thing first. Is this a jetson nano 2gb or 4gb problem? We have lxde enabled on 2gb and gdm3 on 4gb.

Also, do you run apt-get upgrade/update very often? We need to try to reproduce this issue locally. If this could be hit by apt-upgrade/update, then we can try to reproduce it.

It is also better if you can dump the syslog when error happens. But I guess you cannot do it now since it has been working.

I am using 4gb version. I dint update it often.
If it was during reboot after any updates, I would have mentioned it.

This happened when system was shutdown on previous night and tried to switch it back.

I am sure the last sudo apt-update or upgrade was done 10 days back and this issue occured 2 days before after which i posted it under another topic.

But I am using the latest os image.

Yes… that explains why I see the desktop from 4gb nano on the video shared by Manuel_Orsini…
It sounds weird that 4gb hit a problem of “lxde” which is not enabled by default.

I fixed this with @Aravind_Seenu thread. Thank you very much for the help. My jetson is a Jetson Nano 2GB. Thanks for the help too @WayneWWW


Just some personal suggestion… if you can access the terminal. Dump the log before you do the fix steps first…
Your log will help us debug this issue so that other people will not hit this…

But anyway… glad you can work now.