Can't boot Ubuntu 14.04 LTS after CUDA 7 install

Howdy folks,

I have a Dell Precision M4700 equipped with a Quadro K2000M. It’s a dual boot machine where I have one drive dedicated to Windows 7 and another to Ubuntu 14.04 LTS.

I followed the instructions for installing CUDA 7 ( http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#post-installation-actions ) to the letter, and this was right after a fresh installation of Ubuntu 14.04 LTS (I did perform updates/upgrades, but I did not install anything else).

Basically, after the following instructions (on a fresh install of Ubuntu 14.04 LTS):

sudo dpkg -i cuda-repo-ubuntu1404_7.0-28_amd64.deb sudo apt-get update
$ sudo apt-get install cuda

and then followed by a reboot, then it gets stuck at the purple ubuntu screen with the Ubunto logo and the five dots beneath - every time. It still boots fine into Windows.

Can someone please help me out?

Thanks in advance

G

+1. Exact same problem here, same hardware setup. I’ve tried various approaches, such as the ones at:

http://jiakaizhang.com/fix-frozen-after-login-in-ubuntu-14-04/

But nothing seems to work. I had to re-install OS, and then the problem happened again once I installed CUDA (as part of trying to install CAFFE). Any suggestions greatly appreciated.

One thing I just tried - go into BIOS (via f2 at boot start) and then video section, and disable “Optimus”.

I can now boot to desktop, although I get a system error dialog box reading “System program problem detected” [Do you want to report problem now] occasionally. So still not satisfied everything is working correctly…

Hi Davec

Thanks for your insights.

So, are you saying that you also have a Dell Precision M4700 with Quadro K2000M, two drives, dual boot?

Thanks
G

  • Use nvidia-xconfig - manipulate X configuration files for the NVIDIA driver .
  • If this is optimus notebook with Intel and Nvidia GPU then try install nvidia-prime package OR try :

ftp://download.nvidia.com/XFree86/Linux-x86_64/349.16/README/optimus.html
ftp://download.nvidia.com/XFree86/Linux-x86_64/349.16/README/randr14.html

Hi Sandip,

I think you are pointing me in the right direction thanks.
I have installed nvidia-prime, but I am not sure what to do with it (sorry, I am a novice). It doesn’t give me the choice as to what GPU to use.

I have read the links you sent me, and I think I understand it, but as for manipulating configuration files, I am not quite sure what to do exactly.

Now, I have discovered something: I am always able to completely boot and log into Ubuntu when I select, in GRUB, “Advanced Options for Ubuntu”, and then select Ubuntu, with Linux 3.16.0-30-generic (note that my default is Ubuntu, with Linux 3.16.0-38-generic). Once I am logged in, none of the CUDA stuff works. But when I reboot again. and then this time in the default version (3.16.0-38-generic), then it actually boots completely and let’s me log in, and all the CUDA stuff works (i.e. the samples). So I have to do this flip-flop alternate booting scheme as described above.

Thanks

G

Hi Galto2000:

Have you solve the problem? I just encounter the same problem as you, can you give some suggestions?

Thanks
jian

hey guys :)

I have had the same issue and I think I have found the cause. Please check this out:
http://askubuntu.com/questions/603212/nvidia-gtx-860m-ubuntu-14-04-blackscreen/665119#665119

Hi,
I had the same problem. After I installed Cuda 7.5 on the already installed nvidia-352 driver, booting only succeeded 1 out of 5 trials. I did everything I could google in the web, but it all failed. However, I finally solved the issue when I removed all the previous nvidia drivers with “sudo apt-get remove --purge nvidia-*” and reinstall them with “sudo apt-get update” and “sudo apt-get install nvidia-352…”. Thus, I assume that installing Cuda and Cudnn packages caused some bugs for the existing nvidia driver. I hope this helps for someone who is in the same trouble.

Even I am facing same issue. When I used “sudo apt-get remove --purge nvidia-*” I am getting
W: Not using locking for read only lock file /var/lib/dpkg/lock
E: Unable to write to /var/cache/apt/
E: The package lists or status file could not be parsed or opened

I am new to these things so can anyone provide detailed procedure for solving the issue.