Can't Create Cuda Project With Visual Studio 2013

I have Cuda 5.5 x64 installed on Visual Studio 2013 with Windows 7. When I try to create a project using the ‘Cuda 5.5 Runtime’ template I get the message “Failed to create project - The template path ‘C:\ProgramData\NVIDIA GPU Computing Toolkit\v5.5\extras\visual_studio_integration\CudaProjectVsWizards’ does not exist”. But I checked that directory and it does exist. How can I fix this?

Cuda 5.5 (and also I believe 6.0 RC) is not compatible with VS 2013 out of the box… there might be workarounds available that you can Google. VS2012 is supported to work under either version.

I did some research after my post and found out the same thing. And with 6.0 only the Nsight plugin is compatible with VS 2013. The thing is most people who report a problem between VS 2013 and Cuda 5.5 say that they can’t get Cuda to install at all. But my installation went fine and everything seems to work. The only problem is the path error message I get when trying to create a new project. I have searched for workarounds but can’t find anything.

Does anyone else know if it is possible to get this combination to work?

I thought 6.0 RC is comparable with VS2013?

6.0 RC is not compatible with VS2013:
http://developer.download.nvidia.com/compute/cuda/6_0/rc/docs/CUDA_Getting_Started_Windows.pdf

Lerner, is there a specific reason you want to use VS 2013? C11 features are only supported host-side, and some are already implemented in VS2012: http://www.geeks3d.com/20130314/c11-compiler-support-vs2012-vs-gcc-vs-clang/

If you want full C11 support host side, use Linux/Unix+gcc and remember to process it separately as a cpp file. See: https://devtalk.nvidia.com/default/topic/716117/cuda-programming-and-performance/cudafe-error-when-using-c-11-constructs-on-rhel5/

I want to use VS 2013 because that’s what I purchased and installed. I have been learning on it intensively for the last several months. So I don’t want to have to downgrade and unlearn what I already know. I was hoping to move on to learning CUDA programming. But maybe that’s just not possible now. Might have to wait another year or whatever it takes for them to come out with a compatible version.

Not that I know anything about Windows but why not just using VS2012 Express for learning CUDA?

Following on sascha’s suggestion, you can definitely install VS2012 and perhaps use that toolchain from within VS2013. So effectively you’d be using the previous compiler with the new VS2013 GUI.

I’m not sure if the former applies to the Express version though, as I have not tried that… the Express version lacks x64 support by default and some massaging must be done to get CUDA to work correctly on it, but at the very least those workarounds are more documented online… for example:

https://devtalk.nvidia.com/default/topic/714373/cuda-setup-and-installation/configure-cuda-5-5-for-visual-studio-studio-express-2012/

See also:
https://devtalk.nvidia.com/default/topic/589217/vs2012-express-and-cuda-5-5-error/
http://blog.norture.com/2012/10/gpu-parallel-programming-in-vs2012-with-nvidia-cuda/

You should be able to use VS2012 Express with CUDA by following the above to add the correct build rules/includes/libraries at the very least.

Hello, I installed VS2010, 2012 and 2013, CUDA 6.0 Toolkit, NSight VS Edition RC1.
the sample CUDA projects are compiled and can be executed.
but my VS (2010-2013) does not contain the CUDA project template.
How could I add this template to all versions of VS ?
Thanks

I’m assuming you installed the CUDA toolkit before you installed a specific VS suite, thus the templates didn’t get copied to the right place. You can uninstall/reinstall the CUDA toolkit, checking the options for VS2010 and VS2012 support and that should fix it. Remember VS 2013 toolchain is not currently supported under CUDA 6.0, as mentioned before.

I installed VS2013 first, then the CUDA driver, then CUDA toolkits, and then NSight
when I realied that I need VS2012 toolchain, I installed VS2012 and VS2010
I manually copied Build Customizations to MSBuilds/… directory
and I tryed to setup C++ project for working with CUDA, but it does not work…

other question I have is could I use Intel C++ toolchain instead VS2012 ?
how to configure ?

also the keywords and variables of CUDA are not taken in consideration by compiler…

Error 1 error C2065: ‘threadIdx’ : undeclared identifier
Error 2 error C2228: left of ‘.x’ must have class/struct/union
Error 3 error C2065: ‘blockIdx’ : undeclared identifier
Error 4 error C2065: ‘blockDim’ : undeclared identifier
Error 5 error C2059: syntax error : ‘<’
6 IntelliSense: identifier “threadIdx” is undefined
7 IntelliSense: identifier “blockIdx” is undefined
8 IntelliSense: identifier “blockDim” is undefined
9 IntelliSense: expected an expression

I reinstalled CUDA toolkits (cuda_6.0.26_rc_winvista_win7_win8.1_general_64)
no changes !!!

You mention reinstall… did you uninstall it first? I know that the 5.5 installer configures correctly if you install it last, have not tried with the 6.0 installer personally, but I can only assume it behaves similarly if you select the options to install the Visual Studio support for the 2010 and 2012 version. So you can try the 5.5 installer if you really care about templates… otherwise the instructions I have linked above should take care of configuring VS from a Win32 project with the CUDA build properties… it mentions either 5.0 or 5.5, but it should work very similarly with 6.0. There is also a video attached to the thread, which might be useful in configuring it.

In re: “keywords and variables of CUDA are not taken in consideration by compiler” – I assume you mean highlighting… see: https://www.google.com/#q=cuda+intellisense+visual+studio+2012

  • I assume you mean highlighting…
    no compiler errors that stop compilation

  • did you uninstall it first?
    non I installed directly and chose only toolkit option,
    there are no options for integration into VS in 6.0

Again, uninstall the toolkit completely and re-install it, or as I mentioned install the 5.5 toolkit. If you have compiler errors, you have not set up the environment correctly. Take the time to go over the link:

https://devtalk.nvidia.com/default/topic/714373/cuda-setup-and-installation/configure-cuda-5-5-for-visual-studio-studio-express-2012/
Watch the video and get familiar with the environment. All that you need to set it up correctly has been posted in this thread.

I would like to ask if somebody could explain me how to manually create and add the CUDA 6.0 Project Template into VS2013 (2012,2010) ?

The default installation of CUDA 6.0 Toolkit does not install these templates into VS !!! (I tried 2 times)

Thank you in advance !

does CUDA 5.5 toolkit support Tesla K40 GPU ?
what is the difference between 5.5 and 6.0 version ?
could I work with VS2013 using the 5.5 version ?

Thanks!

Do I need to un-install only CUDA Toolkit 6.0 or all other things (Docs, Samples, Drivers,…) ?

does CUDA 5.5 toolkit support Tesla K40 GPU ?
what is the difference between 5.5 and 6.0 version ?
could I work with VS2013 using the 5.5 version ?