Can't debug app on Windows with latest NSIGHT 2024.1

I’ve just fresh installed CUDA 12.4 with NSIGHT VSE 2024.1 and when I try to debug my code, which is a CUDA/C++ plugin within Adobe Premiere 2024, I get exceptions when starting Premiere, before my code is even loaded.
The exception is “Unhandled exception at 0x00007FFF99E23EA0 (NvCudaDebuggerInjection.dll) in Adobe Premiere Pro.exe: 0xC0000005: Access violation reading location 0x0000000000000020.” I’m unable to suppress those and continue.
I get this popup error too: “NVIDIA Nsight Next-Gen Debugger: Attempting to debug on an unsupported CUDA device.”

I have dual GPUs: GeForce GTX 970 (display), and Quadro RTX 6000 (for compute). My driver version is 551.76 (quite recent I think). Windows 11, fully updated.

I tried older CUDA versions as well, and they behave the same way.

Is there any way to attach the Nsight debugger to a running process after it starts up? It seems like there are some environment vars that have to be set up or something.

The stack trace at exception is this, so it looks like Premiere is setting up CUDA:

>	NvCudaDebuggerInjection.dll!00007fff99e23ea0()	Unknown
 	NvCudaDebuggerInjection.dll!00007fff99f238d4()	Unknown
 	NvCudaDebuggerInjection.dll!00007fff99f23d8f()	Unknown
 	nvcuda64.dll!00007ff8064e4ad4()	Unknown
 	nvcuda64.dll!00007ff8064e4caa()	Unknown
 	nvcuda64.dll!00007ff80648154e()	Unknown
 	nvcuda64.dll!00007ff8063975c8()	Unknown
 	nvcuda64.dll!00007ff806535af2()	Unknown
 	REDCuda-x64.dll!00007fff9121b27a()	Unknown
 	REDCuda-x64.dll!00007fff91219fee()	Unknown
 	REDCuda-x64.dll!00007fff9121aeb5()	Unknown
 	REDCuda-x64.dll!00007fff9121f1b9()	Unknown
 	REDCuda-x64.dll!00007fff9121edd1()	Unknown
 	REDCuda-x64.dll!00007fff9121e153()	Unknown
 	REDCuda-x64.dll!00007fff91213dd2()	Unknown
 	REDCuda-x64.dll!00007fff91211a7e()	Unknown
 	REDCuda-x64.dll!00007fff91238083()	Unknown
 	REDCuda-x64.dll!00007fff9123a39c()	Unknown
 	REDCuda-x64.dll!00007fff9123a1f2()	Unknown
 	REDCuda-x64.dll!00007fff9123a4b9()	Unknown
 	REDCuda-x64.dll!00007fff91228e11()	Unknown
 	GPUFoundation.dll!00007fffac5a7b00()	Unknown
 	GPUFoundation.dll!00007fffac5a4e97()	Unknown
 	GPUFoundation.dll!00007fffac48c83c()	Unknown
 	DisplaySurface.dll!00007fffb82f945c()	Unknown
 	Mezzanine.dll!00007fffc2ae1ed8()	Unknown
 	dvacore.dll!00007ff81ffa8775()	Unknown
 	dvacore.dll!00007ff81ffa846c()	Unknown
 	dvacore.dll!00007ff81ffaa5f8()	Unknown
 	dvacore.dll!00007ff81ffaa68b()	Unknown
 	Frontend.dll!00007ff80522e2d6()	Unknown
 	Frontend.dll!00007ff80522dfd9()	Unknown
 	Frontend.dll!00007ff80525bd61()	Unknown
 	Frontend.dll!00007ff80525c762()	Unknown
 	Frontend.dll!00007ff80525c91a()	Unknown
 	Adobe Premiere Pro.exe!00007ff6a7501eaa()	Unknown
 	Adobe Premiere Pro.exe!00007ff6a7502de6()	Unknown

Hi, @garyo

Thanks for using our latest release and sorry for the issue you met.
As you have Geforce GTX970 which is Maxwell, note Maxwell do not support next-gen debugger.
So would you please launch VSE with CUDA_VISIBLE_DEVICES set to the RTX GPU ?

Hi; I’ve tried that (CUDA_VISIBLE_DEVICES=0, rebooted, restarted VS) but now the Nsight debugger silently doesn’t launch from Visual Studio. The cursor spinner appears for a few seconds, but then the spinner goes away. I don’t see any error messages anywhere.

Hi, @garyo

What do you mean “Nsight debugger silently doesn’t launch from Visual Studio” ?
Can you check if your sample now run on Quadro RTX 6000 by default ?

Hi, @garyo

Have you resolved the issue ?