Can't debug on several different IDEs only launching works

I’ve installed the CUDA Toolkit and developed my Application in CLion and launched it with Microsoft Visual Studio 2022 Community as a Toolset. I’ve now run into issues with my Application. So I tried to debug it. I’ve installed “Nsight Integrations” and tried it directly in VS 2022. In VS 2022 I wasn’t even able to launch the application. The .cu isn’t recognized as a file that can be launched.
Then I’ve tried “Nsight Visual Studio Edition” a similar issue occurred. When trying to launch my .cu file, I am getting the error “Unable to launch cuda-gdb on non-Linux system”. I’ve found a thread in this forum with no answer and the same error.
To make sure that Nsight is working correctly, I’ve checked my Nsight Monitor, and it tells me “The Nsight Monitor is properly configured”.

I really don’t know what to do anymore. It is really hard to develop a working application if there is no way to debug it.
Any idea what might be the issue here? I appreciate any help with this issue.