Cant display an image using jetcam and IPython.display on jetson nano


I am using a jetson nano with a Logitech C270 camera plug in with USB. I am running on the latest Jetpack 4.5.1 version.

I am trying to experiment inference within the L4t-ml docker container but I can’t manage to display the live feed from my camera. I run the docker with the --privilege tag and I have access to the camera without problem (I can activate the LED and I managed to print an image using matplotlib). However, following the Getting started with jetson nano course (chapter Hello Camera) I tried running the same jupyter notebook script (see screenshot) to just display the camera feed but instead of an Image I get a string in the output. Do I miss a package in my docker container to get this working ?

Thank you

Have a reference to below topic.

I solved the issue, the installation of jupyter in the l4t docker container was lacking the package ‘ipywidgets’ so I did theses steps to install it :

  1. Install curl : apt install curl

  2. Install nodejs : curl -sL | bash -

  3. Update jupyter : jupyter lab clean & jupyter lab build

  4. Install ipywidgets : jupyter labextension install @jupyter-widgets/jupyterlab-manager

And then it worked.