Can't find jetson-io.py

Hi, I’m trying to configure my gpio pins on my Jetson Nano. It’s installed with JetPack 4.6.1, L4T version: 32.7.1.
However when I try to run ‘sudo /opt/nvidia/jetson-io/jetson-io.py’, I get an ‘sudo: /opt/nvidia/jetson-io/jetson-io.py: command not found’ error. I’ve tried going into the directory and I can’t find the jetson-io.py file either.

Can anyone tell me how I can fix this issue?

How about flashing JetOS again?

Does that involve reflashing the Jetson Nano using the boot loader? I’d rather not have to clean install my Jetson Nano since it has a lot of libraries already installed that were quite a pain to get working.

Oh No!

  1. copy jetson-io directory from a normal Jetson Nano and test it
  2. backup installed library info, dpkg or pip3
dpkg --get-selections
pip3 freeze

3, sth else?

Do you know what could’ve caused this issue? Maybe a bad install of JetPack 4.6.1?

I agree, sth wrong during installation.
On my desk, I have a Jetson Nano devkit like you, definately JP4.6.1.
It was initialized through the SDKManager, and has jetson-io as expected.

So maybe I can try reinstalling JP4.6.1 using Nvidia SDK Manager? I believe I installed JP4.6.1 originally on my jetson nano using the Package Management Tool installing the Debian packages.

If you have a Nano devkit, find an another SD card for fresh installation.

And just copy/save the jetson-io directory from the fresh installed SD card onto my older SD card with all my libraries installed and seeing if running the command again works?

To test!
Cause I did not try that

Thanks! This worked for me.

Good!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.