I have a custom carrier board + NX production board + Samsung NVMe M.2 drive.

Im trying to install the OS on the external drive due to the 16GB built in limitation. The flash is reported as successful but on the first boot i get the error shown in the image attached.

I wonder if its because i should not use the jetson-xavier-nx-devkit-emmc external command?

This is the procedure i followed:

From this site, you can download the L4T archive you’re interested in using:

incidentally, I tried to then use the Xavier NX module back in my original carrier board that was all working but with a SD card, and I got the same error there. So I have two not working systems now unfortunately.


If you want to use the external one, you have to tell the bootloader the UUID before you flash the board.

Here is the step:

Thanks I managed to get it to work in the end by using this process / script.

1 Like

Sure. That should work too.

But please be careful that such tool is not maintained by us directly. Thus, this may breakdown if new release comes out.