Can't flash initial setup on TX2

Well, this is a little frustrating out of the gate.

Brand new TX2.

Go to do the setup. Have a Ubuntu 16.04 machine as host. Run the Jetson L4T 3.1 installer. Everything on host gets set up fine. Next step is to install on target. Jetpack opens the “Post Installation Jetson TX2” with all the awesome things it’s going to do. I flash the system.

Now, no matter what network config I try, including using an ethernet cable between the host and target machine, or trying to have them both correct to a router (the TX2 by Wi-Fi and the host by Ethernet), I get the same error.

JetPack is unable to determine the IP address of the Jetson Developer kit. Failure to run bash command "timeout 180 nc -l 33338" because of error: exit status 1, nc: Address already in use.
Please select which action do you want:
1. Retry
2. Manually enter IP address

Ok, I’ve tried them both by typing in “1” or “2” and pressing enter. 1 just gives me the same error , and every time I type “2” and press enter, it simply closes the Post Installation terminal window and my session is over.

What is going on here? Any ideas?

WiFi will not work for this step, but the direct ethernet should if the PC is chosen as router (host going to router via WiFi is fine…the Jetson can’t go through WiFi for this step). There is a setup option during install to mark host as router before the flash…if this was not correct then perhaps some of the setup did not complete. Even so, if the host is set up as a DHCP server, you will see a DHCP request in “dmesg” some time during the boot up of the Jetson. The only question there is if the host is set up as a router.

I tried with both connecting via switch and router to each other, as well as connecting directly via ethernet, they both give me the same error.

At this point, I would have to say that either this TX2 is broken, Jetpack 3.1 is busted, there is a fault in the setup instructions, or I’m doing something wrong. The last is more likely, but not a given.

Here is a quick recording of me going through the setup.

I appreciate any thoughts on why this is happening.

https://youtu.be/n1ecBcOrt9M

So we know the Jetson itself flashed and has an IP address. JetPack does not let you enter the address though after flash succeeds and the Jetson has rebooted.

First, make sure you can ping that address from the host, and then try ssh from command line to accounts “nvidia” and “ubuntu” from command line without using JetPack. Make sure that the system isn’t firewalling you or being rejected due to ssh not liking something (routers can have firewall functions, and ssh can remember old keys and get upset over a key change).

Once this is done, it is important to note that you can re-run JetPack without package installs to host, and without flash to Jetson. After the Jetson is up and you can ping and ssh works, only then start JetPack, and uncheck all options other than installing packages to the Jetson. Can this now install to Jetson? Will it accept an address?

So I can SSH in just fine under both accounts.

Not flashing the OS seemed to work ok. Everything seems to be installed, though the cuDNN libraries aren’t under the CUDA /usr/local/CUDA like they normally are on a traditional Ubuntu CUDA install.

At that point where it couldn’t find the address, I just connected the ethernet port and found the ip address of tegra from my router, entered it at the retry prompt and it continued with installing additional packages.

This nc error message is indicating you already have a process running on your host machine using that port. This likely occurred if your aborted an earlier installation while trying to determine the ip address.

Look for any nc processes, as follows, and kill them.

$ sudo ps aux | grep 33338
ssparks  32023  0.0  0.0  18624   800 ?        S    13:09   0:00 timeout 180 nc -l 33338
ssparks  32024  0.0  0.0   9180   904 ?        S    13:09   0:00 nc -l 33338
$ kill -9 32024 32023

Then selection option 1 to retry.