Can't flash TX1 using SDK - it fails at 16% every time

I’ve tried re-installing Ubuntu 18.04 a couple of times. I’ve tried several different TX1 boards. They all get to this same point and fail:

17:19:57 INFO: Flash Jetson TX1 - flash: Sync'ing system.img ... done.
17:20:47 INFO: Flash Jetson TX1 - flash: system.img built successfully.
17:20:47 ERROR: Flash Jetson TX1 - flash: command terminated with error

This is always about 15% or 16%. This has included a never-used-before TX1. These are all a few years old boards.

This is with SDK version 1.6.1.8175, Electron 7.1.2, and Ubuntu 18.04.6.

I’ve spent an entire day on this. It’s extremely frustrating. What do I do next? I’m almost ready to throw these boards away if there’s no way to use them.

ThanksSDKM_logs_JetPack_4.6_(rev.1)_Linux_for_Jetson_TX1_2021-09-29_12-32-05.zip (195.1 KB)

And a fairly bizarre solution: I downgraded to Jetpack 4.5.1(rev1) and it worked. I did have to manually run:

apt install cuda-cross-aarch64-10-2
apt install cuda-curand-cross-aarch64-10-2 
apt install cuda-npp-cross-aarch64-10-2 
apt-get -y install cuda-cross-aarch64-10-2=10.2.89*
apt install cuda-cufft-cross-aarch64-10-2
apt-get -y install cuda-cross-aarch64-10-2=10.2.89*

to get CUDA tools to install so it could complete, but after that… success, a working TX1.

I must say, wow, I need a dedicated real hardware (not VM) Ubuntu 18.04 machine, which is totally obsolete by now, and the current release of Jetpack appears to NEVER HAVE BEEN EVEN TESTED on a TX1 before release. Seriously?

HI,

It looks like a problem in sdkmanager. Not an issue only to TX1, which may also happen to jetson nano. And it only happened to jetapck4.6.

Your error in first comment seems has nothing to do with CUDA… The first one is failed in OS installing. But OS installing does not need CUDA.

Please use the export button on sdkm to dump the full error log. Thanks.

1 Like

Ok, I did a fresh Ubuntu installation and did the flashing and again it failed. I saved the debug log. What do I do with it? It’s a zip file. Thanks.

BTW of course I got the same CUDA error as well. I don’t know how to turn off the CUDA installation during this. I am of the belief that if I run your software on a fresh installation of a compatible Ubuntu installation and try to do the most basic things with it, it should work. If I’m able to get 100% repeatable errors, it makes me wonder, did anyone test this at all before release?

You can edit your post and use the icon for “upload” to attach the zip file to the thread. Should be the 7th icon going from left to right.

Note: On your own posts you will see a pencil icon at the bottom right. That is for editing.

1 Like
  1. This forum can upload file as @linuxdev’s comment here.

  2. The flash OS and CUDA installation sound like different problem. We need your log to tell what is going on. Actually, these two can be done separately. You can choose not need to install CUDA in the GUI and flash OS only.

  3. This is tested before release. But we cannot control everyone’s host setup. Thus, sometimes we we still get user reporting error. Also, some users from different location may hit different network error due to the CDN around the world. That’s why we are here to deal with your problem.