Can't generate makefile when install netcdf-4.4.1

I want to install netcdf-4.4.1 to my computer, and I just followed the method introduced at this site. the version of netcdf I am installing is not same as the site’s. So, I am faced with the problem.
The problem is about “cmake”.For the latest version of netcdf, after installing the zlib and hdf5, it’s needed to generate a makefile of netcdf with “cmake” instruction. When I run the cmake instruction, the shell show the message like this:

-- HDF5: Using hdf5 compiler wrapper to determine C configuration
-- Found HDF5 libraries version 1.10.4
-- Found libdl: /usr/lib/x86_64-linux-gnu/
-- Found Math library: /usr/lib/x86_64-linux-gnu/
-- Found bash: /usr/bin/bash

Configuration Summary:

-- Building Shared Libraries:     ON
-- Building netCDF-4:             ON
-- Building DAP Support:          ON
-- Building Utilities:            ON

Tests Enabled:              ON
-- DAP Remote Tests:  ON
-- DAP AUTH Tests:    OFF
-- Extra Tests:       OFF
-- Coverage Tests:    OFF
-- Parallel Tests:    OFF
-- Large File Tests:  OFF


-- Build Type:           DEBUG
-- CMAKE_C_COMPILER:     /usr/bin/cc
-- CMAKE_C_FLAGS:        
-- CMAKE_C_FLAGS_DEBUG:  -g -Wall -Wconversion
-- Linking against:      /usr/lib/x86_64-linux-gnu/hdf5/serial/;/usr/lib/x86_64-linux-gnu/hdf5/serial/;/usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/;/usr/lib/x86_64-linux-gnu/

# NetCDF C Configuration Summary

# General
NetCDF Version:		4.4.1
Configured On:		2021年 04月 01日 星期四 16:25:24 WITA
Host System:		x86_64-Linux-5.8.0-48-generic
Build Directory: 	/home/xuan/Desktop/WORK_DIR/netCDF/netcdf-4.4.1
Install Prefix:         /usr/local

# Compiling Options
C Compiler:		/usr/bin/cc
CFLAGS:			 -g -Wall -Wconversion
LDFLAGS:		  -Wl,--no-undefined
Shared Library:		yes
Static Library:		no
Extra libraries:	-lhdf5_hl -lhdf5 -lpthread -lsz -lz -ldl -lm -lcurl

# Features
NetCDF-2 API:		yes
HDF4 Support:		no
NetCDF-4 API:		yes
NC-4 Parallel Support:	no
PNetCDF Support:	no
DAP Support:		yes
Diskless Support:	yes
MMap Support:		no
JNA Support:		no

-- Configuring done
CMake Error at CMakeLists.txt:1336 (ADD_EXECUTABLE):
  Cannot find source file:


  Tried extensions .c .C .c++ .cc .cpp .cxx .cu .m .M .mm .h .hh .h++ .hm
  .hpp .hxx .in .txx
Call Stack (most recent call first):
  nc_test4/CMakeLists.txt:68 (add_bin_test)

CMake Error at CMakeLists.txt:1336 (ADD_EXECUTABLE):
  No SOURCES given to target: nc_test4_tst_fill_attr_vanish
Call Stack (most recent call first):
  nc_test4/CMakeLists.txt:68 (add_bin_test)

CMake Generate step failed.  Build files cannot be regenerated correctly.

What’s wrong for this situation?