Can't get cuda-drivers ubuntu package. NVidia server error 504

W: Failed to fetch  504  Gateway Timeout [IP: 80]
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package cuda-drivers

Today installation was fine.

This is happening to me today. Been trying for 2 or 3 hours to install CUDA toolkit. Have tried the network installer, the local installer, the local shell script, all error out with 504.

Err:12  InRelease
  504  Gateway Timeout [IP: 80]

and, following the instructions on

--2020-06-18 12:33:06--
Resolving (
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 504 Gateway Timeout


Is this a just a semi-regular thing that you need to wait out?

Edit: Okay, I’m in New Zealand trying this locally. I logged into a remote AWS instance and it worked fine. So must be some sort of local DNS issue.

1 Like