Can't get the RTX 3070 NVIDIA drivers to run sucessfully on Ubuntu 18.04

Hey all!

I’ve been trying to set up nvidia for a couple of days now, but I can’t get it to run properly.

So the issues at hand are mainly the following three:

  1. When I run nvidia-settings I only seem to get the GPU 0 panel as shown in the attached image. So, I’m missing all the other panels with system information etc. Additionally when I check the terminal output I get the following error message:

(nvidia-settings:28412): GLib-GObject-CRITICAL : 14:44:08.969: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** ** Message: 14:44:09.006: PRIME: No offloading required. Abort

** Message: 14:44:09.006: PRIME: is it supported? no

  1. When I open system details it doesn’t indicate that my RTX 3070 is in use (shown in second image).

  2. When I run the command ubuntu-drivers devices I get the following output:

WARNING:root:_pkg_get_support nvidia-driver-510: package has invalid Support PBheader, cannot determine support level
WARNING:root:_pkg_get_support nvidia-driver-510-server: package has invalid Support PBheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.1/0000:01:00.0 ==
modalias : pci:v000010DEd000024DDsv000017AAsd00003A4Fbc03sc00i00
vendor : NVIDIA Corporation
driver : nvidia-driver-510 - third-party non-free
driver : nvidia-driver-470 - distro non-free recommended
driver : nvidia-driver-510-server - distro non-free
driver : nvidia-driver-470-server - distro non-free
driver : xserver-xorg-video-nouveau - distro free builtin

== /sys/devices/pci0000:00/0000:00:02.2/0000:04:00.0 ==
modalias : pci:v00008086d00002723sv00008086sd00000080bc02sc80i00
vendor : Intel Corporation
manual_install: True
driver : backport-iwlwifi-dkms - distro free

dkms status outputs:
nvidia, 510.60.02, 5.4.0-107-generic, x86_64: installed

sudo mokutil --sb-state outputs:
Secureboot is disabled

inxi -Gx outputs:
Graphics: Card-1: NVIDIA Device 24dd bus-ID: 01:00.0
Card-2: Advanced Micro Devices [AMD/ATI] Device 1638
bus-ID: 05:00.0
Display Server: x11 (X.Org 1.20.8 )
drivers: nvidia,fbdev,ati (unloaded: modesetting,vesa,radeon,nouveau)
Resolution: 1920x1080@77.00hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0, 128 bits)
version: 3.3 Mesa 20.0.8 Direct Render: Yes

sudo lshw -C display outputs:
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: iomemory:fa0-f9f iomemory:fc0-fbf irq:95 memory:d0000000-d0ffffff memory:fa00000000-fbffffffff memory:fc00000000-fc01ffffff ioport:3000(size=128) memory:d1080000-d10fffff
*-display UNCLAIMED
description: VGA compatible controller
product: Advanced Micro Devices, Inc. [AMD/ATI]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:05:00.0
version: c5
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
configuration: latency=0
resources: iomemory:fc0-fbf iomemory:fc0-fbf memory:fc10000000-fc1fffffff memory:fc20000000-fc201fffff ioport:1000(size=256) memory:d1500000-d157ffff

uname -r outputs:

Upgrading to 20.04 lts is not an option, as I need to work with Unreal engine and nvidia omniverse, which as of now only partially supports ubuntu 20.04

I would really appreciate any help to resolve the problems at hand.

nvidia-bug-report.log.gz (570.7 KB)

Please see this:

Though this might need additional changes since 18.04 didn’t support amd hybrid graphics, only intel.

Hi generix!
Thank you very much for your response. I’ve upgraded the kernel via the liquorix ppa to version:

uname -r

And also reinstalled the nvidia driver. However, now I can’t access nvidia-smi or nvidia-settings anymore. I tried to analyze the issue and realized that the /etc/X11/xorg.conf file and the /etc/X11/xorg.conf.d/ directory is gone. Could that be the root cause of the issue?

See attached bug report for detailed insight:
nvidia-bug-report.log.gz (123.7 KB)

You installed an incompatible kernel package from mainline. Please use the liquorix ppa instead.

Thanks generix!

I’ve installed the suggested kernel now and it seems to solved all the issues. However, one thing I’ve noticed now is that every now and then when I boot up into Ubuntu is that the cursor splits after moving it from the initial position and once that happens everything slows down until to the point that it seems to be completely frozen.

I noticed that this only happens when I reboot the machine. If I power it off and start it this way everything works like a charm.

nvidia-bug-report.log.gz (403.3 KB)

NVRM: Xid (PCI:0000:01:00): 31

Since this only happens on a warm boot, I suspect the bios does not properly reset the nvidia gpu. Please check for a bios update.

I also noticed that the issue appears after returning from hibernation mode. And each time I boot the machine after it was completely powered off I get a lot of “clear orphaned node” messages, which don’t seem to show up when I reboot the machine.

And unfortunately updating the bios on my machine through Ubuntu is not supported, as Lenovo doesn’t provide an ISO file to create a bootable CD, from which I could update the bios. I could install windows next to Ubuntu for that matter, but is there anything else I can try before doing that?

UPDATE: I dualbooted my machine now and update the bios in windows, but the problem still persists.

You could use cudagpumemtest to rule out a VRAM defect.