Can't install cuda 6.5 on vanilla Ubuntu 14.10 after multiple tries

I’ve been trying to install cuda 6.5 for a couple days without success on what I consider to be
a pretty plain vanilla system. I am running;

  • Linux Mint 17.1 (Rebecca ~ Ubuntu 14.10)
  • Cinnamon 64-bit
  • gcc 4.8.2 (originally had 4.9 but this led to various error messages so I changed)

To install cuda I run which leads to

You are attempting to install on an unsupported configuration. 
Do you wish to continue? ((y)es/(n)o) [ default is no ]:

I’ve learned to say yes even though I don’t understand why it objects to my configuration (running
nvidia-smi gives):

Fri Jan 16 21:08:20 2015       
| NVIDIA-SMI 340.65     Driver Version: 340.65         |                       
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 750 Ti  Off  | 0000:01:00.0     N/A |                  N/A |
| 40%   31C    P8    N/A /  N/A |    469MiB /  2047MiB |     N/A      Default |
| Compute processes:                                               GPU Memory |
|  GPU       PID  Process name                                     Usage      |
|    0            Not Supported                                               |

The first time I tried the installation I accepted its offer to install a video driver which was a BIG mistake. Cinnamon got blown away somehow and I had to uninstall my video drivers and cuda 6.5 and start over. The driver I was using originally was 343.36 and I thought maybe that was causing the problem so I went to Nvidia 340.65 as shown above.

When the cuda installation is completed I run deviceQuery and get

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

I’ve tried running the install in a terminal while in Cinnamon and I’ve tried it by first stopping mdm but the result is always the same.

At this point I don’t what to try next…

Linux Mint 17 is not an officially supported distro for CUDA 6.5, and niether is Ubuntu 14.10

Cripes. You’re right, I missed the fact that 14.04 is supported but not 14.10. However, RC 7 does support 14.10 (and gcc 4.9.1) so I will give that a try.

I’ve discovered that when Mint went from 17 (Qiana) to 17.1 (Rebecca) they stayed with the Ubuntu 14.04 code base instead of going to 14.10 so apparently that isn’t the issue.

So my configuration is GTX 750 Ti, Ubuntu 14.04 code base, gcc 4.8.2, kernel 3.13.0-24 and nvidia driver 340.65. I even confirmed my glibc was 2.19 (ran ldd --version).

This seems to be dead on with the requirements.