Can't install CUDA on Jetson Nano

Hi all, I’ve tried several forums including the official CUDA installation guide. Everything runs fine in the pre-installation until I get to this command: sudo apt-get install linux-headers-$(uname -r)
in the Ubuntu section which yields:

E: Unable to locate package linux-headers-4.9.299-tegra
E: Couldn’t find any package by glob ‘linux-headers-4.9.299-tegra’
E: Couldn’t find any package by regex ‘linux-headers-4.9.299-tegra’

Link here: CUDA Installation Guide for Linux

I also tried the instructions here as this corresponds to my Ubuntu 18 and desired 11.x CUDA version. But to no avail either. I get a lot of missing packages and things and nothing works. I’m using the latest flashed image for the Nano.

If I run the fix broke install command this is what I get:

krypto@nano1:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  apt-clone archdetect-deb bogl-bterm busybox-static cryptsetup-bin
  dpkg-repack gir1.2-timezonemap-1.0 gir1.2-xkl-1.0 grub-common
  kde-window-manager kinit kio kpackagetool5 kwayland-data kwin-common
  kwin-data kwin-x11 libdebian-installer4 libkdecorations2-5v5
  libkdecorations2private5v5 libkf5activities5 libkf5attica5
  libkf5completion-data libkf5completion5 libkf5declarative-data
  libkf5declarative5 libkf5doctools5 libkf5globalaccel-data libkf5globalaccel5
  libkf5globalaccelprivate5 libkf5idletime5 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5kcmutils-data libkf5kcmutils5 libkf5kiocore5
  libkf5kiontlm5 libkf5kiowidgets5 libkf5newstuff-data libkf5newstuff5
  libkf5newstuffcore5 libkf5package-data libkf5package5 libkf5plasma5
  libkf5quickaddons5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data
  libkf5sonnetcore5 libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5
  libkf5waylandclient5 libkf5waylandserver5 libkf5xmlgui-bin libkf5xmlgui-data
  libkf5xmlgui5 libkscreenlocker5 libkwin4-effect-builtins1 libkwineffects11
  libkwinglutils11 libkwinxrenderutils11 libqgsttools-p1 libqt5designer5
  libqt5help5 libqt5multimedia5 libqt5multimedia5-plugins
  libqt5multimediaquick-p5 libqt5multimediawidgets5 libqt5opengl5
  libqt5quickwidgets5 libqt5sql5 libqt5test5 libxcb-composite0 libxcb-cursor0
  libxcb-damage0 os-prober python3-dbus.mainloop.pyqt5 python3-icu python3-pam
  python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtwebkit
  qml-module-org-kde-kquickcontrolsaddons qml-module-qtmultimedia
  qml-module-qtquick2 rdate tasksel tasksel-data
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libnvidia-compute-450 libnvidia-gl-450
The following NEW packages will be installed:
  libnvidia-compute-450 libnvidia-gl-450
0 upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
71 not fully installed or removed.
Need to get 0 B/64.1 MB of archives.
After this operation, 257 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 file:/var/cuda-repo-ubuntu1804-11-0-local  libnvidia-compute-450 450.51.05-0ubuntu1 [9,231 kB]
Get:2 file:/var/cuda-repo-ubuntu1804-11-0-local  libnvidia-gl-450 450.51.05-0ubuntu1 [54.9 MB]
debconf: delaying package configuration, since apt-utils is not installed
(Reading database ... 218428 files and directories currently installed.)
Preparing to unpack .../libnvidia-compute-450_450.51.05-0ubuntu1_arm64.deb ...
Unpacking libnvidia-compute-450:arm64 (450.51.05-0ubuntu1) ...
dpkg: error processing archive /var/cuda-repo-ubuntu1804-11-0-local/./libnvidia-compute-450_450.51.05-0ubuntu1_arm64.deb (--unpack):
 trying to overwrite '/usr/lib/aarch64-linux-gnu/', which is also in package nvidia-l4t-cuda 32.7.3-20221122092935
Preparing to unpack .../libnvidia-gl-450_450.51.05-0ubuntu1_arm64.deb ...
Unpacking libnvidia-gl-450:arm64 (450.51.05-0ubuntu1) ...
dpkg: error processing archive /var/cuda-repo-ubuntu1804-11-0-local/./libnvidia-gl-450_450.51.05-0ubuntu1_arm64.deb (--unpack):
 trying to overwrite '/usr/share/glvnd/egl_vendor.d/10_nvidia.json', which is also in package nvidia-l4t-3d-core 32.7.3-20221122092935
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

any help would be appreciated

CUDA is preinstalled on the Nano. Don’t try to install it.

Okay, might be why this is so difficult and full of errors… Do you know how I can check the versions available and overall compatibility? There are some packages I want to run that have been tested on 10.x and even 11.x but I have come to understand that Nano might lack support for 11 and above.
Thanks for your response!

ls -l /usr/local | grep cuda

It’s 10.2


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.