Can't install CUDA Toolkit

I have downloaded the toolkit installers for 6.5.14, 6.0.37, 5.5.20, and 5.0.35, and installation fails on all of them. I have just installed an NVIDIA GeForce GTX 750 card and the drivers for it. The GTX 750 seems to be working just fine.

Computer: HP Pavilion desktop with Intel i7-3770 CPU running at 3.4 GHz
RAM: 10 GB
OS: Win 7 Home Premium (64-bit)
Available HD space: C: 810 GB, E: 463 GB

All of the toolkit installers I have downloaded are for Win7/Vista desktop, 64-bit.

For the 6.5, 6.0, and 5.5 toolkit versions, if I double-click on any of them, I get a dialog that says 7-Zip: Data Error.

I’m running 7-Zip v9.20, which I re-installed yesterday (10/20/2014).

If I open 7Zip File Manager and use it to open the install files, it creates all of the directories, but the files inside are all empty (0 bytes).

The 5.0 version of CUDA Toolkit comes as an MSI file. If I double-click this file, the installer starts, and eventually displays a dialog that says this:
“The cabinet file ‘CudaTookitInstaller64.cab’ required for this installation is corrupt and cannot be used. This could indicate a network error, an error reading from the DC-ROM, or a problem with this package.”

I have looked in half of the 39 pages of posts in the “CUDA Setup and Installation” section of this forum, but haven’t found this problem listed. (Possibly it was posted in the half that I didn’t look at.)

Can someone advise me so that I can move forward on getting the CUDA Toolkit to install?
Mark

If your GTX750 is working correctly and has a recent driver, then go ahead and install the CUDA 6.5 toolkit. Ignore the fact that it says it can’t find supported hardware. You will need to de-select the option to install the driver – you want to leave your existing driver intact. Leave the options selected to install the CUDA toolkit and the samples.

After that things should work normally/correctly for you. When a GPU card is released after a particular CUDA toolkit is released, then that toolkit may not “recognize” the card. But you should still be able to install the toolkit. The only thing that needs to match your GPU is the driver.

And you don’t need 7-zip. The installer is a standalone executable. Don’t run it with 7-zip. If double-clicking on the installer is launching or using 7-zip, something is wrong and you may want to completely uninstall 7-zip from your machine (you may have a file association problem.)

txbob,
Thanks for replying. I don’t think I have a file association problem. When I attempt to install v6.5, the CUDA Setup Package starts up, and gets to 7% before it dies. It then generates an error dialog that says “7-Zip: Data Error”. I have removed 7Zip from my machine, so I’m puzzled about why I’m getting this error. I did a search using Win Explorer for 7zip.exe, and didn’t find anything. I also did a search through the registry for “7zip.exe” as a key, value, or data, and didn’t find anything.

The CUDA setup package creates several directories, and populates them with some files. The two top-level directories are CUDASamples and CUDAToolkit. The CUDASamples directory contains only the 6_Advanced directory. The CUDAToolkit directory contains directories named extras, jre, and libnvvp. The lowest-level directories (several directories down in the hierarchy) each contain one file, so at least something is happening.

Things are about the same for the v6.0 and v5.5 toolkits.

My only guess would be corrupted downloads or unstable system. Maybe someone else will have ideas.

May be you need to be administrator…not sure, but give a try.

Also, you can check user account control(UAC) and relax the policy a bit.

I already am the admin on this machine.

I don’t think that’s it, either.

I believe that the files are corrupted. The published checksums don’t agree with the ones I get using the MSFT File Checksum Integrity Validator (FCIV.exe).

I checked one of the CUDA toolkit versions yesterday, but didn’t save my findings. I’ll to another check on the 6.5 and 6.0 versions and post my findings here.

My next step is to see if someone else has reported this problem and entered it as a bug. If not, I’ll enter a bug myself. I’m a noob here, so I wasn’t able to do so yesterday, but I should be able to do this in a day or two.

Anyway, problem still not solved, but I appreciate the responses fron txbob and rajserc!

Mark

What makes you think it’s a bug? My first guess would be to suspect that your download process is corrupting the file. If the file itself were corrupted as posted, don’t you think someone else would have noticed? (Lots of people download and use these, including myself…)

I’m not following your logic. Go ahead and file a bug if you want. Not sure what you think the defect is. (The actual file posted for download is corrupted, across all the CUDA versions you tried? Doesn’t seem plausible.)

Maybe you should try downloading from a completely different machine, and then transfer the file on a USB key, and see if you can run the installer that way.

Are you using IE or Chrome or some common browser to download the files?

NVIDIA publishes MD5 checksums which you should be able to use to check the integrity of downloaded packages:

https://developer.nvidia.com/cuda-downloads/checksums

It seems you have already done that. As txbob points out, it is unlikely that corrupted download packages are posted a this time, they would long have been detected due to complaints from users. As additional anecdotal evidence that there is nothing wrong with the posted packages: I installed a 64-bit Windows 7 package of CUDA 6.5 last week, and it installed flawlessly.

I agree with txbob that the issue is in all likelihood local to your machine.

I’m using IE 11 to download the files. I agree that it’s probably not reasonable to assume that all four of the files I’ve downloaded are corrupted at the server end.

In any case, the 6.5 version I’ve downloaded is definitely corrupted. The published MD5 checksum for cuda_6.5.14_windows_general_64.exe is b2c43a2489e1d66bd6fad45cab41c2ca.

Using fciv.exe (MSFT File Checksum Integrity Verifier), I get an MD5 checksum of 5d62bfc0532832c6ff55c544b89cfac7.

I’ll see if downloading with Chrome makes a difference.

I downloaded the CUDA toolkit v6.5 using Chrome this time.
The MD5 checksum for this file is 71f2f2d32b54d471dd05125eba2e4f81 (again using fciv.exe as described in my previous post). This checksum is different from the checksum that is published at the site in the link posted by njuffa.

Any other ideas? I’ve downloaded numerous other items in the past and haven’t had any problems with them. I’m running an AV program and keep it up to date. I also run Malwarebytes on a regular basis.

Downloading from a different machine is a good idea, but I don’t have another one immediately available.

I just used fciv and it gave me the correct result for a particular download:

C:\Users\txbob\Downloads>fciv -md5 cuda_6.5.14_windows_notebook_64.exe
//
// File Checksum Integrity Verifier version 2.05.
//
c42600f7c2744ae87e1f6a8112986a3c cuda_6.5.14_windows_notebook_64.exe

C:\Users\txbob\Downloads>

So I believe your general process is correct, at least.

are you downloading from:

http://www.nvidia.com/getcuda

What file size is your downloaded CUDA 6.5.14 windows desktop 64-bit file? It should be just about 1 GB (990MB).

Yes.

It shows as 990 MB (1,038,691,048 bytes).

BTW, I’m also using v2.05 of fciv.exe.

Update: I have successfully downloaded the CUDA Toolkit package.

The problem was my wireless router (supplied by my cable/ISV provider), which apparently mangles large files. I contacted the NVIDIA customer support folks, who came up with a number of suggestions, one of which was to bypass my wireless router. To surmount this problem, I ran an ethernet cable directly from my router to my computer, and that was the key.