Can't install gobject-introspection for python binding usage on Jetson with Deepstream 6.3

**• Hardware Platform Jetson
**• DeepStream Version 6.3
**• JetPack Version 5.1.2 GA
**• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
**• Issue Type bugs
**• How to reproduce the issue ? sudo apt install gobject-introspection

Deepstream C++ test applications work fine but i can’t install python binding from GitHub - NVIDIA-AI-IOT/deepstream_python_apps at v1.1.8 (v1.1.8 is the good version to target deepstream 6.3 )

I try to install binaries or compile binding i have the same error. python need dependencies to gobject-introspection.
if i try to install it via sudo apt install gobject-introspection, i have an error :

The following packages have unmet dependencies:
gobject-introspection : Depends: libgirepository-1.0-1 (= 1.64.0-2) but 1.64.1-1~ubuntu20.04.1 is to be installed

gobject-introspection depends of libgirepository-1.0-1 from 1.64.0 to 1.64.2 and version 1.64.1-1 is installed , so what’s the problem ?

Did you also hit this error when installing the wheel? Releases · NVIDIA-AI-IOT/deepstream_python_apps · GitHub . Installing the wheel should be the most straightforward way and there should be no dependency issues.
If you are building the bindings, make sure to follow the steps ( deepstream_python_apps/bindings at v1.1.8 · NVIDIA-AI-IOT/deepstream_python_apps · GitHub).
Please provide the full steps&logs before the error happens if there is still such an issue.

Hello,

when i say “I try to install binaries” i’am talking about install wheel. i show you pip install pyds-1.1.8-py3-none-linux_aarch64.whl output result bellow :

Processing ./pyds-1.1.8-py3-none-linux_aarch64.whl
Collecting PyGObject
Using cached pygobject-3.48.2.tar.gz (715 kB)
Installing build dependencies … done
Getting requirements to build wheel … done
Installing backend dependencies … done
Preparing wheel metadata … error
ERROR: Command errored out with exit status 1:
command: /opt/exavision/env/bin/python3.8 /tmp/tmp_c535g9e prepare_metadata_for_build_wheel /tmp/tmp4vivwtjw
cwd: /tmp/pip-install-a_74kqlc/PyGObject
Complete output (23 lines):
+ meson setup /tmp/pip-install-a_74kqlc/PyGObject /tmp/pip-install-a_74kqlc/PyGObject/.mesonpy-zal2wd55 -Dbuildtype=release -Db_ndebug=if-release -Db_vscrt=md -Dtests=false -Dwheel=true --wrap-mode=nofallback --native-file=/tmp/pip-install-a_74kqlc/PyGObject/.mesonpy-zal2wd55/meson-python-native-file.ini
The Meson build system
Version: 1.4.0
Source dir: /tmp/pip-install-a_74kqlc/PyGObject
Build dir: /tmp/pip-install-a_74kqlc/PyGObject/.mesonpy-zal2wd55
Build type: native build
Project name: pygobject
Project version: 3.48.2
C compiler for the host machine: cc (gcc 9.4.0 “cc (Ubuntu 9.4.0-1ubuntu1~20.04.2) 9.4.0”)
C linker for the host machine: cc ld.bfd 2.34
Host machine cpu family: aarch64
Host machine cpu: aarch64
Program python3 found: YES (/opt/exavision/env/bin/python3.8)
Found pkg-config: YES (/usr/bin/pkg-config) 0.29.1
Run-time dependency python found: YES 3.8
Found CMake: /usr/local/bin/cmake (3.29.2)
Run-time dependency gobject-introspection-1.0 found: NO (tried pkgconfig and cmake)
Not looking for a fallback subproject for the dependency gobject-introspection-1.0 because:
Use of fallback dependencies is disabled.

../meson.build:29:9: ERROR: Dependency 'gobject-introspection-1.0' is required but not found.

A full log can be found at /tmp/pip-install-a_74kqlc/PyGObject/.mesonpy-zal2wd55/meson-logs/meson-log.txt
----------------------------------------

ERROR: Command errored out with exit status 1: /opt/exavision/env/bin/python3.8 /tmp/tmp_c535g9e prepare_metadata_for_build_wheel /tmp/tmp4vivwtjw Check the logs for full command output.

Please install dependencies first

sudo apt install python3-gi python3-dev python3-gst-1.0 python-gi-dev git \
    python3 python3-pip python3.8-dev cmake g++ build-essential libglib2.0-dev \
    libglib2.0-dev-bin libgstreamer1.0-dev libtool m4 autoconf automake libgirepository1.0-dev libcairo2-dev

Yes i follow pre install step , output result of debian package install :
sudo apt install python3-gi python3-dev python3-gst-1.0 python-gi-dev git python3 python3-pip python3.8-dev cmake g++ build-essential libglib2.0-dev libglib2.0-dev-bin libgstreamer1.0-dev libtool m4 autoconf automake libcairo2-dev
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
autoconf est déjà la version la plus récente (2.69-11.1).
automake est déjà la version la plus récente (1:1.16.1-4ubuntu6).
build-essential est déjà la version la plus récente (12.8ubuntu1).
cmake est déjà la version la plus récente (3.16.3-1ubuntu1).
g++ est déjà la version la plus récente (4:9.3.0-1ubuntu2).
libcairo2-dev est déjà la version la plus récente (1.16.0-4ubuntu1).
libtool est déjà la version la plus récente (2.4.6-14).
m4 est déjà la version la plus récente (1.4.18-4).
python3 est déjà la version la plus récente (3.8.2-0ubuntu2).
python3-dev est déjà la version la plus récente (3.8.2-0ubuntu2).
python3-gi est déjà la version la plus récente (3.36.0-1).
python-gi-dev est déjà la version la plus récente (3.36.0-1).
python3-gst-1.0 est déjà la version la plus récente (1.16.2-2).
git est déjà la version la plus récente (1:2.25.1-1ubuntu3.11).
libglib2.0-dev est déjà la version la plus récente (2.64.6-1~ubuntu20.04.6).
libglib2.0-dev-bin est déjà la version la plus récente (2.64.6-1~ubuntu20.04.6).
libgstreamer1.0-dev est déjà la version la plus récente (1.16.3-0ubuntu1.1).
python3.8-dev est déjà la version la plus récente (3.8.10-0ubuntu1~20.04.9).
python3-pip est déjà la version la plus récente (20.0.2-5ubuntu1.10).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 188 non mis à jour.

Everything is up to date.

Why not install this library?

I tried to install the gobject-introspection-1.0 library but it does not exist in this exact version:

sudo apt install gobject-introspection-1.0
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
E: Impossible de trouver le paquet gobject-introspection-1.0
E: Impossible de trouver de paquet correspondant à l’expression rationnelle « gobject-introspection-1.0

I tried to install the library in a more generic way without specifying the version :

sudo apt install gobject-introspection
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Certains paquets ne peuvent pas être installés. Ceci peut signifier que
vous avez demandé une configuration impossible, ou bien, si vous utilisez
la distribution « unstable », que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’« Incoming ».
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
gobject-introspection : Dépend: libgirepository-1.0-1 (= 1.64.0-2) mais 1.64.1-1~ubuntu20.04.1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

I have given the correct command

sudo apt install python3-gi python3-dev python3-gst-1.0 python-gi-dev git \
    python3 python3-pip python3.8-dev cmake g++ build-essential libglib2.0-dev \
    libglib2.0-dev-bin libgstreamer1.0-dev libtool m4 autoconf automake libgirepository1.0-dev libcairo2-dev

If you want to install gobject-introspection independently, it should be

sudo apt install libgirepository1.0-dev

Excuse me, I removed this package from my script because it was the one that caused the problem, by executing your command I came across this dependency problem again

sudo apt install python3-gi python3-dev python3-gst-1.0 python-gi-dev git \
 python3 python3-pip python3.8-dev cmake g++ build-essential libglib2.0-dev \  libglib2.0-dev-bin libgstreamer1.0-dev libtool m4 autoconf automake libgirepository1.0-dev libcairo2-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
autoconf est déjà la version la plus récente (2.69-11.1).
automake est déjà la version la plus récente (1:1.16.1-4ubuntu6).
build-essential est déjà la version la plus récente (12.8ubuntu1).
cmake est déjà la version la plus récente (3.16.3-1ubuntu1).
g++ est déjà la version la plus récente (4:9.3.0-1ubuntu2).
libcairo2-dev est déjà la version la plus récente (1.16.0-4ubuntu1).
libtool est déjà la version la plus récente (2.4.6-14).
m4 est déjà la version la plus récente (1.4.18-4).
python3 est déjà la version la plus récente (3.8.2-0ubuntu2).
python3-dev est déjà la version la plus récente (3.8.2-0ubuntu2).
python3-gi est déjà la version la plus récente (3.36.0-1).
python-gi-dev est déjà la version la plus récente (3.36.0-1).
python3-gst-1.0 est déjà la version la plus récente (1.16.2-2).
git est déjà la version la plus récente (1:2.25.1-1ubuntu3.11).
libglib2.0-dev est déjà la version la plus récente (2.64.6-1~ubuntu20.04.6).
libglib2.0-dev-bin est déjà la version la plus récente (2.64.6-1~ubuntu20.04.6).
libgstreamer1.0-dev est déjà la version la plus récente (1.16.3-0ubuntu1.1).
python3.8-dev est déjà la version la plus récente (3.8.10-0ubuntu1~20.04.9).
python3-pip est déjà la version la plus récente (20.0.2-5ubuntu1.10).
Certains paquets ne peuvent pas être installés. Ceci peut signifier que 
vous avez demandé une configuration impossible, ou bien, si vous utilisez
la distribution « unstable », que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'« Incoming ».
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgirepository1.0-dev : Dépend: libgirepository-1.0-1 (= 1.64.0-2) mais 1.64.1-1~ubuntu20.04.1 devra être installé
                          Dépend: gobject-introspection (= 1.64.0-2) mais ne sera pas installé
                          Dépend: gir1.2-glib-2.0 (= 1.64.0-2) mais 1.64.1-1~ubuntu20.04.1 devra être installé
                          Dépend: gir1.2-freedesktop (= 1.64.0-2) mais 1.64.1-1~ubuntu20.04.1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

if I try to install only libgirepository1.0-dev I have the same problem :


sudo apt install libgirepository1.0-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent pas être installés. Ceci peut signifier que 
vous avez demandé une configuration impossible, ou bien, si vous utilisez
la distribution « unstable », que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'« Incoming ».
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgirepository1.0-dev : Dépend: libgirepository-1.0-1 (= 1.64.0-2) mais 1.64.1-1~ubuntu20.04.1 devra être installé
                          Dépend: gobject-introspection (= 1.64.0-2) mais ne sera pas installé
                          Dépend: gir1.2-glib-2.0 (= 1.64.0-2) mais 1.64.1-1~ubuntu20.04.1 devra être installé
                          Dépend: gir1.2-freedesktop (= 1.64.0-2) mais 1.64.1-1~ubuntu20.04.1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Run the following command firstly and then reinstall the dependencies.

sudo apt-get update
sudo apt-get install -f

Update is Ok.

sudo apt-get update
Atteint :1 https://download.docker.com/linux/ubuntu focal InRelease
Atteint :2 http://ports.ubuntu.com/ubuntu-ports focal InRelease                
Atteint :3 http://ports.ubuntu.com/ubuntu-ports focal-security InRelease       
Atteint :4 https://nvidia.github.io/libnvidia-container/stable/deb/arm64  InRelease
Atteint :5 https://repo.download.nvidia.com/jetson/common r35.4 InRelease      
Atteint :6 https://repo.download.nvidia.com/jetson/t234 r35.4 InRelease        
Réception de :7 https://packages.microsoft.com/repos/code stable InRelease [3,590 B]
Réception de :8 https://packages.microsoft.com/repos/code stable/main arm64 Packages [17.4 kB]
Réception de :9 https://packages.microsoft.com/repos/code stable/main armhf Packages [17.2 kB]
38.2 ko réceptionnés en 1s (37.1 ko/s)
Lecture des listes de paquets... Fait

Install is ok too.

nvidia@tegra-ubuntu:~$ sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 188 non mis à jour.

sudo apt-get update and sudo apt-get install -f run without fail but the problem persist, i can’t install libgirepository1.0-dev or gobject-introspection

I don’t know what happened to your system. you can try to use sdkmanger to re-burn.

Or use docker

sudo docker pull nvcr.io/nvidia/deepstream:6.3-gc-triton-devel

xhost +

docker run --runtime nvidia -it --rm --net=host --privileged -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.3 nvcr.io/nvidia/deepstream:6.3-gc-triton-devel

/opt/nvidia/deepstream/deepstream/user_deepstream_python_apps_install.sh --version 1.1.8

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks