Can't install operating system on brand new Jetson Xavier

Something went wrong during the first attempt to install the OS (from the boot image). It started up fine initially, I initiated the install, but it crashed sometime in the middle of the install, and now every time I try to start it up, it gets stuck in a boot loop. Nothing I do seems to get it back. I tried the following:

  • Tried creating a brand new image (including a brand new SD card, in case the one I tried initially was bad or something) and trying to re-install (it will not boot, just gets stuck in the boot loop)
  • Tried installing the OS from the SDK - This seems to work initially, and it gets to the point that it stops and tells me to go on the Jetson to setup the username/password. However, I can’t do that because of the boot loop. I can’t get to any point where I have any control over what it does on startup.
  • Tried connecting to it via console. I can see the output from the boot. There are no major errors that I can see, but I guess that I don’t really know what to look for.

Are there any permanent settings that would need to be cleared after a failed install? On a regular motherboard, I might take out the battery for a few minutes. I’m not sure if there is anything similar on the Jetson. Certainly the Jetson booted when I got it, I tried an install, and now it doesn’t boot regardless of what SD card is there.

A full Xavier has eMMC. Is this actually an Xavier, or is it perhaps an NX? If this is an Xavier with eMMC, then does flashing to use eMMC without involving the SD card work?

Mostly you’d just need to flash again. If the problem persists, then you’d want to post a serial console boot log.

Yeah, that did it. Turns out I just needed to take the SD card out, and it started up into the setup and allowed me to set up the user. Thanks!