Cant install Pytorch on JetsonNano P3450

Thanks for your reply.I have 1 more problem -no module named cv2 error and multiple errors.[Check pictures below]


Sequenece of my actions:
Pytorch install:

1.conda create -n pytorch3.6 -c conda-forge python=3.6

2.conda activate pytorch3.6

3.pip install --upgrade pip

[instructions : PyTorch for Jetson]

4.wget https://nvidia.box.com/shared/static/p57jwntv436lfrd78inwl7iml6p13fzh.whl -O torch-1.8.0-cp36-cp36m-linux_aarch64.whl

5.sudo apt-get install python3-pip libopenblas-base libopenmpi-dev libomp-dev

6.sudo apt-get install libomp5

7.pip3 install Cython

  1. pip3 install numpy torch-1.8.0-cp36-cp36m-linux_aarch64.whl

9.pip install Pillow

10.pip install cmake

  1. pip3 install numpy torch-1.8.0-cp36-cp36m-linux_aarch64.whl

12.python.

  1. import torch

  2. print(torch.version)

15.print('CUDA available: ’ + str(torch.cuda.is_available()))

16.pip install opencv-python

  1. pip install opencv-python was interrupted after 1 hour.

18.pip install jupyterlab

  1. jupyter lab

I ignored all these errors and jupiter lab was launched.(So ,in my point of view, i can keep ignore these errors).But i need cv2 module and thats why i tried to: ‘’ pip install opencv-python’’ .But process was interrupted after 1 hour.

I also tried to repeat all steps without pip install opencv-python, but the result was same.So cv2 module didnt install by default.

Commands sudo apt-get install python3-opencv and sudo apt-get install python-opencv didnt help.
As a result:
1.Python
2.import cv2
3.import error no module cv2

How can i install it?How can i fix errors during installation of jupyter lab [ Can i ignore them]?

I got it.Problem in python 3.6.I installed open-cv in new venv with python 3.7.1 without any problems by: pip install opencv-python.Building wheels infinite for python 3.6 only.So Do you have pytorch version for python 3.7.1 and jetpack 4.6.1 or do you have specific version of open-cv for python 3.6?

I found specific version of opencv and installed it [Ipython3 -m pip install opencv-python==4.6.0.66 --verbose].