Can't install via .run on CentOS 7 the latest beta version 375.28

I tried to install via the sudo-.run method the latest driver for Linux on my CentOS 7 system with GTX 980Ti and 1070.
I’m running Folding@home (right now with nV 370.280 and get same error messages as under Windows (see http://nvidia.custhelp.com/app/answers/detail/a_id/4288 )

22:00:45:WU00:FS01:0x21:Completed 4750000 out of 6250000 steps (76%)
22:00:57:WU00:FS01:0x21:ERROR:exception: Error downloading array energyBuffer: clEnqueueReadBuffer (-5)
22:00:57:WU00:FS01:0x21:Saving result file logfile_01.txt
22:00:57:WU00:FS01:0x21:Saving result file log.txt
22:00:57:WU00:FS01:0x21:Folding@home Core Shutdown: BAD_WORK_UNIT
22:00:58:WARNING:WU00:FS01:FahCore returned: BAD_WORK_UNIT (114 = 0x72)

So I tried the latest beta in the hope the issue get solved but run into this installer trouble:

/tmp/selfgz2282/NVIDIA-Linux-x86_64-375.26/kernel/nvidia-uvm/uvm8_pmm_gpu.h: In function ‘uvm_gpu_chunk_set_size’:
/tmp/selfgz2282/NVIDIA-Linux-x86_64-375.26/kernel/nvidia-uvm/uvm8_pmm_gpu.h:157:41: error: expected expression before ‘=’ token
#define UVM_CHUNK_SIZE_MASK_SIZE (ilog2(UVM_CHUNK_SIZE_MAX) + 1)
^
/usr/src/kernels/3.10.0-327.36.3.el7.x86_64/include/linux/log2.h:155:10: note: in definition of macro ‘ilog2’
(sizeof(n) <= 4) ? \

full log file see here: http://pastebin.com/60CnUsYu

Kernel: Linux linuxpowered 3.10.0-327.36.3.el7.x86_64 #1 SMP Mon Oct 24 16:09:20 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
GCC: gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC)

For the time I need to stay on 370.28 but would appreciate if the installer issue above could be addressed.