Can't load local .usd file through .yaml file with replicator composer

So I was following this tutorial: https://www.youtube.com/watch?v=HHzNIh72B_Y but the models weren’t loading. No matter what I write in the .yaml as a value for the parameter “scenario_model” it keeps returning this error:


2023-08-01 15:19:32 [4,670ms] [Error] [omni.replicator.composer.scripts.parser] [omni.replicator.composer] Could not connect to the Nucleus server: omniverse://localhost/NVIDIA/Assets/Isaac/2022.2.1. Only local data will be fetched.
Traceback (most recent call last):
  File "tools/composer/src/main.py", line 95, in <module>
    mount=args.mount,
  File "Omniverse/Library/isaac_sim-2022.2.1/extscache/omni.replicator.composer-1.2.10+lx64/omni/replicator/composer/scripts/composer.py", line 87, in __init__
    mount=mount,
  File "/home/user/Omniverse/Library/isaac_sim-2022.2.1/extscache/omni.replicator.composer-1.2.10+lx64/omni/replicator/composer/scripts/parser.py", line 97, in __init__
    self.params = self.parse_input(input_file)
  File "/home/user/Omniverse/Library/isaac_sim-2022.2.1/extscache/omni.replicator.composer-1.2.10+lx64/omni/replicator/composer/scripts/parser.py", line 565, in parse_input
    params = self.parse_params(params)
  File "/home/user/Omniverse/Library/isaac_sim-2022.2.1/extscache/omni.replicator.composer-1.2.10+lx64/omni/replicator/composer/scripts/parser.py", line 503, in parse_params
    self.parse_paths(params)
  File "/home/user/Omniverse/Library/isaac_sim-2022.2.1/extscache/omni.replicator.composer-1.2.10+lx64/omni/replicator/composer/scripts/parser.py", line 372, in parse_paths
    paths = _verify_paths(key, [path], correct_file_types)
  File "/home/user/Omniverse/Library/isaac_sim-2022.2.1/extscache/omni.replicator.composer-1.2.10+lx64/omni/replicator/composer/scripts/parser.py", line 326, in _verify_paths
    raise ValueError(f"Parameter {key} has path {path} not found on {self.nucleus_server} or locally.")
ValueError: Parameter scenario_model has path /NVIDIA/Assets/Isaac/2022.2.1/Isaac/Environments/Simple_Warehouse/warehouse.usd not found on None or locally.
2023-08-01 15:19:32 [4,987ms] [Warning] [carb.audio.context] 1 contexts were leaked
./python.sh: line 41: 28254 Segmentation fault      (core dumped) $python_exe "$@" $args
There was an error running python

Sometimes, if I try to load another .yaml example instead of “NVIDIA/Assets/Isaac/2022.2.1/Isaac/Environments/Simple_Warehouse/warehouse.usd” the path it tries to open is instead “NVIDIA/Assets/Isaac/2022.2.1/ /Isaac/Environments/Simple_Warehouse/warehouse.usd” with an extra “/” between the model path and the nucleus server path.

I have also tried linking some of my own .usd files in the .yaml file but I keep getting this same error message, as if some sort of wrong default path gets opened every time instead of what I’m asking.

1 Like

@salvo.dipp i am just another user, but looks like it’s having connection issue to the OV nucleus server, which could be the cause for not being able to load assets. did you already set up a localhost?

yep, anyway, is it not possile to load your own usd files through the .yaml? because it was still giving this error even when I wasn’t trying to access the nucleus server.

Hi @salvo.dipp , yes you are right. The warehouse.usd scene is preloaded as default scene in case there is no scenario provided. So if you have error connecting to the nucleus server, it will gives you this error. We’ve re-invent the syntax and remove all the default yamls in the new Replicator YAML (Composer 2.0) that has been released.