Can't mount nvcr.io/nvidia/tlt-streamanalytics:v2.0_dp_py2 on folder

• Dell precision Tower/Quadro RTX 5000/(dual GPU)
• NVIDIA Transfer Learning Toolkit V2 to train the YOLO3 model
• docker_tag: v3.21.08-py3

When i run
• `$ sudo docker run –-runtime=nvidia -it -v /home/vaaan/tlt-experiments:/workspace/tlt-experiments -p 8888:8888 nvcr.io/nvidia/tlt-streamanalytics:v2.0_dp_py2/bin/bash

i get this error:
docker: invalid reference format.
See ‘docker run --help’.

sudo docker images |grep tlt

nvcr.io/nvidia/tlt-streamanalytics v3.0-py3 344204c03cbe 3 months ago 17.2GB
nvcr.io/nvidia/tlt-streamanalytics v2.0_dp_py2 496dcdfc093a 17 months ago 7.99GB

$ sudo docker run --runtime=nvidia -it -v /home/vaaan/tlt-experiments:/workspace/tlt-experiments nvcr.io/nvidia/tlt-streamanalytics:v2.0_dp_py2 /bin/bash

unknown shorthand flag: ‘Â’ in - -v
See ‘docker run --help’.

Can modify
–-runtime=nvidia
to
--runtime=nvidia

sudo docker run --runtime=nvidia -it -v /home/vaaan/tlt-experiments:/workspace/tlt-experiments -p 8888:8888 nvcr.io/nvidia/tlt-streamanalytics:v2.0_dp_py2 /bin/bash

its giving this error:
docker: Invalid ip address: 8888.
See ‘docker run --help’

Since you are running TLT 2.0, please refer to Requirements and Installation — Transfer Learning Toolkit 2.0 documentation

And please try without sudo.

I download the TAO Toolkit samples notebooks and it worked.
Thank you,
Morganh