Can't normally boot into Ubuntu 16.04 LTS after CUDA 8 install

I have read the Thread ‘Can’t boot Ubuntu 14.04 LTS after CUDA 7 install’ already. But I dont use a Laptop computer.

What I did before this problem appeared:

  • Fresh install of Kubuntu 16.04.1
  • Complete Upgrade to newest packages
  • reboot
  • CUDA 8 install following this procedure. I opted for installing the CUDA *.deb package
  • reboot > everything worked fine
  • compiled CUDA samples
  • run one of the sampled successfully
  • installed MATLAB, tested MATLAB
  • turned the computer off (shut down)

Next day

  • started the computer
  • black screen with blinking cursor, after some time black screen, monitor turns off (waited 5min)
  • booted into GRUB, started Ubuntu in RECOVERY mode, selected RESUME, booted into X.
  • In RECOVERY X worked, NVIDIA drivers were loaded, checked
matlab@Emt-matlab:~$ nvidia-smi 
Thu Feb 16 14:18:33 2017       
| NVIDIA-SMI 375.26                 Driver Version: 375.26                    |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 960     Off  | 0000:01:00.0      On |                  N/A |
| 20%   48C    P5    18W / 120W |    210MiB /  4037MiB |      0%      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|    0      1365    G   /usr/lib/xorg/Xorg                             144MiB |
|    0      1588    G   kwin_x11                                        24MiB |
|    0      1597    G   /usr/bin/krunner                                 1MiB |
|    0      1615    G   /usr/bin/plasmashell                            38MiB |

worked fine

  • restarted the computer booted in NORMAL (NON-RECOVERY) mode. > black screen with blinking cursor again.
  • So far I am only able to boot into X using RECOVERY mode.


  • booting into RECOVERY now leads into black screen, the monitor stays turned on. I have not changed anything on the system except running nvidia-bug report.


  • I can startx in tty0 via sudo startx and startx in RECOVERY mode.

The attached log files seem to be very empty, even though i could run

XX@XX:~$ sudo startx -- -logverbose 6
[sudo] password for matlab: 
xauth:  timeout in locking authority file /home/matlab/.Xauthority
X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
Current Operating System: Linux Emt-matlab 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:10:15 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-62-generic root=UUID=2f5fd48e-1d3b-41b7-a3ce-2daeaa6dbaa0 ro recovery nomodeset
Build Date: 02 November 2016  10:06:10PM
xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see 
Current version of pixman: 0.33.6
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.2.log", Time: Thu Feb 16 15:12:35 2017
(==) Using system config directory "/usr/share/X11/xorg.conf.d"


root@XX:~# will now collect information about your
system and create the file 'nvidia-bug-report.log.gz' in the current
directory.  It may take several seconds to run.  In some
cases, it may hang trying to capture data generated dynamically
by the Linux kernel and/or the NVIDIA kernel module.  While
the bug report log file will be incomplete if this happens, it
may still contain enough data to diagnose your problem.

Please include the 'nvidia-bug-report.log.gz' log file when reporting
your bug via the NVIDIA Linux forum (see
or by sending email to ''.

Running boot ID has no effect, no persistent journal was found
Specifying boot ID has no effect, no persistent journal was found

If the bug report script hangs after this point consider running with
--safe-mode command line argument.


nvidia-bug-report.RECOVERY-ROOT-XSERVER.log.gz (303 KB)
nvidia-bug-report-RECOVERY.log.gz (251 KB)
nvidia-bug-report-NORMAL-SSH.log.gz (64 KB)