Can't open jetson-io.py on jetson xavier nx

Hi,

We are working on setting up CAN BUS for the nvidia jetson xavier nx for communication with a sensor.

We have a problem with opening the jetson-io.py program for configuring the GPIO-pins. We have followed this CAN-BUS guide: https://docs.nvidia.com/jetson/archives/r35.4.1/DeveloperGuide/text/HR/ControllerAreaNetworkCan.html

and also this guide:
https://docs.nvidia.com/jetson/archives/r35.4.1/DeveloperGuide/text/HR/ConfiguringTheJetsonExpansionHeaders.html#hr-configuringthejetsonexpansionheaders-runningjetsonio

When running the command " sudo /opt/nvidia/jetson-io/jetson-io.py " we see a window popping up and immediately closing.

We have tried to run " sudo /opt/nvidia/jetson-io/jetson-io.py | less " which gives us the error: No DTB found for NVIDIA Jetson Xavier NX Developer Kit!
We get same error opening other files as config-by-function.py etc.

In the /boot/dtb folder we have stored: kernel_tegra194-xavier-nx-cti-NGX007.dtb kernel_tegra194-xavier-nx-cti-NGX007.dtb.sig tegra194-p3668-all-p3509-0000.dtb

Hi adamgm,

Are you using the devkit or custom board for Xavier NX?

What’s your Jetpack version in use?

For me, it seems you are using custom carrier board with custom dtb.
Jetson-IO tool is only available for the devkit.
If you are using the custom carrier board, please use devmem command or pinmux spreadsheet to configure for pinmux instead.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.