Can't open nvidia-settings - ERROR: Unable to load info from any available system


first of all I am aware that there are a lot of threads with the exact same problem, but I was unable to resolve my issue using any of the methods.
I’ve attached the nvidia bug report.
nvidia-bug-report.log.gz (86.7 KB)

I am running CudoOS (which is basically just Ubuntu for mining) with 4 GPUs (GTX1080), and I want to control fan speed manually. I am accessing the machine over SSH. Problem is that, as the title says, I can’t even open nvidia-settings without the error from the title.
What I’ve tried:

  1. Ran nvidia-xconfig with AllowEmptyInitialConfiguration and EnableAllGpus to generace the xorg.conf file
  2. Tried setting the $DISPLAY variable to 0-4, localhost:0 and similar stuff
  3. Ran nvidia-settings as “DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 sudo nvidia-settings”

Nothing works, I just can’t seem to get the settings to work. I’ve also added a 10-nvidia.conf file to /etc/X11/xorg.conf.d with the following content:

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration" "True"
    Option "Coolbits" "28"
    ModulePath "/usr/lib/xorg"

Not sure about the module path, found the xorg folder to be there. I may be missing a whole lot, but am not experienced with running nvidia hardware on Linux, so I hope someone can point me in the right direcion.


Anyone? :/