Can't ping in ad-hoc mode on Jetson TX2

I have two TX2 boards with L4T R32.4.3 and I’m trying to connect them in ad-hoc mode. I’m able to connect without encryption but I can’t ping any device from the other. It says destination host unreachable. Here’s a pic from both devices:

I should mention that after I set the Band to 2.4Ghz and the channel to 1 instead of default and automatic, I was able to ping. But was no longer able to do that after 5 minutes even though I changed literally nothing.

Any help?

Update:

I tried connecting an external usb Wifi adapter and tried to connect in ad-hoc mode, I could connect but still wasn’t able to ping.

However, I was able to set the external adapter in AP mode and connect to it from the other board and successfully pinged. This was not working with the built in wifi chip. With the built in wifi chip, I would create an AP but the created AP could not be seen by other devices even though I changed the op mode as stated here.

I guess this is more likely a software problem rather than a hardware problem.