Cant play youtube videos after installing nvidia drivers

Hello everyone,

yesterday I set up my new pc (MSI X570-A PRO, AMD Ryzen 7 3800x, ZOTAC GAMING GeForce RTX 2070 Super AMP) Ubuntu 18.04. After installing cuda 10.1, using the local .deb file, I realized I couldn’t play youtube videos anymore.

Today I reinstalled everything and still have the same problem.

Any help on this would be much appreciated.

All the best,
Georg

I suspect you were installing full ‘cuda’, which also installs the bundled old driver, overwriting the already installed from ubuntu repo. Please remove anything cuda and nvidia or do a clean reinstall, then install the driver from ubuntu repo.
Afterwards,

  • download the cuda .deb
  • add the repo to your system (first three steps from install instructions on download page)
  • don’t install cuda
  • instead, run sudo apt install cuda-toolkit-10-1
  • set PATH variable if necessary
    Is there a reason you’re using cuda 10.1 instead of 10.2?

Thank you for your answer.

Sadly it is still not working. I need cuda 10.1 since tensorflow currently has no support for cuda 10.

Steps I did:

  • Downloaded the local .deb file form here
  • cd <path to .deb> && sudo dpkg -i cuda-repo-ubuntu1804-10-1-local-10.1.105-418.39_1.0-1_amd64.deb
  • sudo apt-key add /var/cuda-repo-10-1-local-10.1.105-418.39/7fa2af80.pub
  • sudo apt update
  • sudo apt install cuda-toolkit-10-1
  • sudo reboot

After this I tried to run nvidia-smi but the executable was not found. So I installed the nvidia-driver by hand.
Tried multiple versions (440, 435, 390) but none of them worked. (with and without previously installing cuda-toolkit)

I figured that it is just the nvidia-driver that screws with the video playing in the internet.

Do you have any idea what I could try to fix this?

Thanks again for your help!

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).